reception problems with Mi2 / no signal


Apr 27, 2013
8
0
11
#1
I have some Problems with my Mi-2.

It worked fine till a week ago. Now it says “No Service”.
I have no reception. In some areas, near the sending towers, there is a weak reception(Only one bar). It’s not possible to phone. I didn’t change anything on the mi2!

I tried my Sim in another cell phone, a nokia c5 and Xperia T, it got service! Then i tried to put a sim from another provider in the mi2 -> no reception.


I tried to solve the problem by update to the latest system, it doesn't help. Then i tried to do full wipe and reinstall the system. Still no reception.


I think It must be something wrong with the hardware.
 
Dec 11, 2012
120
7
28
#2
My Signal was also better before...
I changed different radio versions but no better. If I change my sim in another phone signal is better.. also other simcard in this phone don't change I have got 1 line Gsm maybe we need to go back to stock version?

Verstuurd van mijn MI 2 met Tapatalk
 
Apr 27, 2013
8
0
11
#3
But the reception disappeared without changing the software, from one to another day.
And it's a big difference from full signal in my Xperia to no signal in the Mi2.
 
Dec 11, 2012
120
7
28
#4
Strange.... I don't know what the problem is but I had better signal before..
Can we test the gsm signal?

Verstuurd van mijn MI 2 met Tapatalk
 
Apr 27, 2013
8
0
11
#6
I tried again now.

For a minute the reception was full, like in my xperia T, but I couldn't call or get called.The Network Type says" UNKNOWN:0"

Then after a minute again: " Emergency calls only"

No reception.
 
Apr 27, 2013
8
0
11
#9
With another Sim card it's the same. For a minute the signal is full, but i can not call or get called. -> "The person you called is temporally not available...."

Turning on /off flight mode doesn't help :(

Actually its the 3.4.26 , but I had the same problems with the older versions.
 
Apr 27, 2013
8
0
11
#15
I don't know how I can flash with adb.exe

Open the programm in cmd, and then ? Never used this before... Only used Miflash
 
Mar 4, 2012
91
2
18
#16
Thanks s010 for posting the radio.
I'm trying to give it a go but can't install it.
When I try to flash it from stock recovery I get an unsigned error.
I can't get my adb to see the phone when it's in fastboot mode. It sees it when it's in stock recovery but shows it as 'offline'. I've tried updating my sdk platform tools and usb driver but nothing will get adb to see the phone when in recovery mode.
Any help appreciated.
Cheers.
 

s01o

Members
May 1, 2012
121
34
40
#17
Thanks s010 for posting the radio.
I'm trying to give it a go but can't install it.
When I try to flash it from stock recovery I get an unsigned error.
I can't get my adb to see the phone when it's in fastboot mode. It sees it when it's in stock recovery but shows it as 'offline'. I've tried updating my sdk platform tools and usb driver but nothing will get adb to see the phone when in recovery mode.
Any help appreciated.
Cheers.
OK!
Install this: http://bigota.d.miui.com/3.4.5/miui_MI2_3.4.5_93a974a0fe_4.1.zip - and update it with miuiandroid last release!

Or see this tread: http://en.miui.com/thread-1683-1-1.html
Or this solution: http://en.miui.com/forum.php?mod=redirect&goto=findpost&ptid=1683&pid=62486
 
Mar 4, 2012
91
2
18
#18
Thanks s010
I think I managed to load the radio using fastboot. The flash reported successful even though adb devices does not report the device as visible.
Had a read of the threads you linked. Seems to be a range of signal associated problems being experienced. In my case I can get H+ but signal strength is poor & intermittent in areas that are fine with other handsets.
Anyway, flashing the 3.4.5 radio does appear to have improved things somewhat.
Will see how it goes.
 
Dec 23, 2012
8
0
21
#20
2 days without signal..:(
It happens after I replace my screen but I don't think there is a connection between the two. (I tried to replace my new screen with my old and still no signal - emergency call only)
But then I though that maybe there is a connection, because first I connect the new screen but I forgot to remove a sticker from a connector - that caused my screen to flickering in the two side of it, and after I remove the sticker the screen wasn't flickering but I can remember if before or after I remove the sticker there was no signal :/
So I don't know ????

When the problems appear my Xiaomi MI2 was at version: 4.6.13, I upgrade it to 4.6.20 and no change - emergency call only.
Baseband version: M9615A-CEFWMAZM-2.0.128017

I tried my sim in another phone - it worked..
(Sometimes I got signal but I can't call and even if I can it's for a sec, and internet doesn't work also..)
So I think I have the same problem as describe in this thread, and I searched and found maybe a solution.
Solution: http://en.miui.com/thread-6913-1-1.html , but I don't understand clearly the steps he wrote at the end of the thread

Can anyone please explain clearly what is the solution from the link, thanks.
 
Last edited:
Dec 23, 2012
8
0
21
#22
Didn't help, the guys who talk about the same problem said that suddenly it worked again.
In the mean time after several flashing through Miflash and I also tried to short circuit (but maybe didn't succeed), NOTHING CHANGE.. still emergency call only...
So it appeared to depend of how much lucky I am.. and maybe suddenly it will work..so it sucks for the moment..
I'm despairing..


Any opinion, suggestion ?
 
Sep 22, 2013
355
132
67
#23
i know that the mi2s don't support 900mhz frequency and it's a problem in some country, not sure if related..

edit, if it was working before, it shouldn't be the problem
 
Dec 23, 2012
8
0
21
#24
Thanks everyone, I send it to reparation (in my country) and actually a resistor is missing and that the cause of the cellular reception lost..
The problem is that it's difficult to find exactly the same resistor and if it's not the same it will not work or it will work but the phone will be buggy :(.
I hopefully waiting the phone will be repair, otherwise I will be forced to send it to china to Xiaomi.
 
Dec 23, 2012
8
0
21
#25
Finally, he didn't succeed to repair even if he put a new resistor.
Because it's not the same, it doesn't work :(
You can see in the picture, (from the internet I found) I upload, at the bottom the resistor he changed.
Maybe this will be helpful for someone in the future...

Here the pic:

Mi-two-1E-front2.jpg
Need to buy a new phone now...
Any suggestion? :)
Personally I though to buy the MI2S 32GB because he is small and powerfull and also because I have now my MI2 in case I broke the MI2S.... screen replacement, etc.. if it's fit and work it would be awesome!