sd-ext error

Discussion in 'Question & Answers' started by rishi06, May 2, 2011.

  1. rishi06

    rishi06Members

    Nov 13, 2010
    8
    0
    11
    Something really weird and really bad is happening to my HTC desire. I had the 1.4.22 XJ D2EXT X PART version of miui and, when the new release came out last friday, decided to do a full wipe and install the 1.4.29 ROM. Only, when I did the full wipe it gave me some weird error on the sd-ext. Still, I tried to flash the new ROM (non-D2EXT). When I opened it, it all worked except for the settings. When I go to menu -> settings, it says the app is not installed. So I did another wipe and, again, it gave me the same error:
    "E: Can't mount /dev/block/mmcblk0p2 (file exists)
    error mounting /sd-ext/"
    I tried formatting the whole SD-card and recreating two partitions, I tried to format SD-ext from the recovery but it gives me that same error. I also tried setting up another SD card, still the same. What went wrong? And most importantly, what can I do? I'm desperate at this point..
     
  2. rugmankc

    rugmankc<b>Forum Donator</b>

    Nov 7, 2010
    308
    0
    38
    Use sdformatter from web and format sd card outside of phone with a card reader to PC. Format Type--Full Erase On and Format Size Adj On.

    Recovery does a poor format job

    Then partition with Amon_Ra 2.2.1--1gb/0 Swap

    Of course do your appropriate bu's

    This will eliminate card as issue

    I would also recommend Dark Tremor 2.7.5.2 or the 2.7.5.2-1. Not the betas yet
     
  3. rugmankc

    rugmankc<b>Forum Donator</b>

    Nov 7, 2010
    308
    0
    38
    Also, HIGHLY recommend wiping 5X everything before flashing new rom :)
     
  4. rishi06

    rishi06Members

    Nov 13, 2010
    8
    0
    11
    Thank you! I usually wipe twice before flashing a new rom, thought it would suffice. Is it the same if I partition the SD on a card reader with gpart on linux?
     
  5. rugmankc

    rugmankc<b>Forum Donator</b>

    Nov 7, 2010
    308
    0
    38
    I don't know, never used them

    Probably the same
     

Share Our Site