Stuck in fastboot ⚠️


Oct 30, 2020
Hi all,

My Xiaomi 13 had HyperOS weekly installed on it with unlocked bootloader.
Then I tried to install MIUI and lock bootloader in which my phone was stuck in recovery mode.
After than, I formatted the phone using recover mode and then booted safe mode.
The phone is now stuck in fastboot mode and not even booting to recovery.

I tried to:
- Unlock bootloader using xiaomi tool: It says I need to enable developer options. The phone can't boot to do so.
- Flash rom again using xiaomi flash tool or flash recovery: Can't flash in locked state.

From what I read online, I need authorised account to unlock bootloader. if that's true, anyone knows a reliable service with fairly good price ?

Any idea on good ones ? I see, for example, XiaomiKey servers are offline always
For those who has the skill, my issue was that I have Chinese version phone which got bricked after locking bootloader with global rom installed.
This causes boot loop to fastboot.
The solution will be to install Chinese fastboot rom using authorised service (found with around 3$ per flash - again, not paid ad btw :D)