New Tesla app no longer works via bluetooth


Jan 12, 2022

First of all I want to say thanks for this ROM, generally everything works very well!

I recently got a new phone (POCO F3) which came with MIUI 12.5, and coming from a Samsung S9 I noticed that the permanent Tesla notification didn't work (there was always a Tesla icon in my notification tray) and with that not working I think it also affects the functionality of being able to walk up to the car and have it auto-unlock.

I installed Arrow OS as I wanted to know if this was an issue with the phone itself or the ROM, and the permanent notification/automatic unlocking features worked on that ROM, so then I did some more reading up on MIUI 13 and the EU version, which is how I came across you guys :)

After installing the stable version of MIUI 13, I can safely say I don't want to go back to Arrow OS as there are so many more features on MIUI and it looks a whole lot cleaner, however I am struggling with having to open the Tesla app and re-authenticate each time I need to get in my car.

Here's what I've tried so far with no success:

1. Disabling battery saver features for the Tesla app.
2. Ensuring the Tesla app has all permissions, such as autostart.
3. Pressing the "lock" icon from the recent apps screen, ensuring that the Tesla app never closes.
4. Checking all my Bluetooth settings are enabled and the car is paired/allows the phone to be used as a key.

However the only way I can get in the car is by using NFC which isn't as ideal as using Bluetooth, so my question is, is there anything else I can do to use Bluetooth as a key or is this something I'm going to have to live with on MIUI?

Thanks for reading,
  • Like
Reactions: UdoLie


Oct 10, 2022

I have the same problem. The Tesla Model Y cannot be opened. I have Mi11 Ultra with MIUI Stable.