[TOPAZ] Is my NFC Chip dead ?


May 21, 2024
I own a Redmi Note 12 4G NFC that previously had OEM HyperOS EEA, I decided to return to Xiaomi.EU ROM, NFC was working before then (and on Xiaomi.EU ROM ver too)

I boot into Xiaomi.EU (This phone has yet to be rooted as of now), NFC was working then,

I installed the latest GPay_module apk, I setup Google Wallet but [This phone does not pass security checks]... I reinstall the GPay_module, clean data on Play services, Wallet, Store and reboot... and on the way i noticed that on the Wallet app "NFC is turned off" even if I press turn on on the app, I assumed it was just because i haven't passed safetynet yet.

and then i realized something is very wrong, as I can't turn on NFC at all (I press the switch to turn on, it turns off immediately, I cannot switch to HCE, it is stuck at SIM Wallet)

I backed up my apps except banking and settings, I did a factory reset, same result.

I flashed the latest stock fastboot MIUI 14 EEA ver 14.0.12 without locking bootloader, i boot into OEM MIUI 14, same result

...this is an issue.

I took some logs (via adb logcat) :

the pinned file is the logcat of what happens when i attempt to turn on NFC (here I did it 2 times)

it looks like the NFC firmware is corrupted...

is this recoverable without opening the phone and/or replacing the NFC chip ?

EDIT : As a last ditch effort i reverted to stock MIUI 14 and locked bootloader, NFC is still gone.

EDIT2 : I have found the suspect, and it is unrelated to Xiaomi.EU, the official crDroid firmware (which is what I was originally flashing before HyperOS refused to work on my device despite being made for it, and there's an active discussion on the Telegram group about this exact issue.
I don't know how to delete this post, so if a moderator can, please and thank you.


  • nfc_logcat.txt
    29.8 KB · Views: 35
Last edited:
Hi. Do you solve the problem with this model? I already sent reports to Xiaomi, but they don't care. Are already 2 months.