Xiaomi Redmi 3 Hardbricked?


alchzor

Members
Jan 11, 2017
4
13
Hi, so I have encountered a rather big issue with my xiaomi redmi 3 pro.
I believe I have flashed wrong (corrupted ? ) ROM, now I have a really annoying situation.
So, I flashed " ido_xhdpi_images_V7.2.6.0.LHPCNDB_20160129.0000.14_5.1_cn " in MiFlash, took a bit long time (nearly 15 minutes), afterwards it was completed, I disconnected my phone, and *BOOM* since then, black.
Current situation is this: When I connect my phone via USB, my phone gets recognized in device manager as
"Qualcomm HS-USB QDLoader 9008 (COM#)", also it gets recognized in MiFlash, but can't get it to work in fastboot, and it is not recognized as adb device. So, throughout 3 days now, I tried nearly EVERYTHING I have found on forums. The only thing I have not done is to take the back cover off and disconnect battery ( as I have seen on forums), tried with deep flash cable, all possible combinations of buttons and all. If the phone is connected to PC, when I press whatever combination of buttons on phone I just get Windows sound for connecting an USB device.
So today, when I connected it, red LED light was blinking, I have no idea what that was, so I plugged it into the wall to charge for 10mins, and now when I connect it, it's gone again, all black, no response whatsoever.

So, when I connect it to MiFlash and try to flash any ROM, tried nearly everyone I found, I get the same message; "Unspecified error 0x80004005; End Transfer packet id0, status 9" if I refresh MiFlash without disconnecting, and press flash again I get "Reached the end of the file. (0x80070026; Receiving hello packet) "

Things maybe to mention: I am running a 64 bit Windows 10, and my bootlocker is locked.

So I am wondering, if there is any possible way to solve this or it's time for a new phone?

Capture1.PNG
Capture2.PNG
Capture3.PNG
Capture4.PNG
 

Pertti Kosunen

Members
Sep 2, 2014
730
82
Qualcomm HS-USB QDLoader port mean it is in EDL mode, you should be able to MiFlash in this mode. Try again after reboot, hold power button 10+ seconds.
 

alchzor

Members
Jan 11, 2017
4
13
Yeah, so I thought as well, but even so, I get back to the same message in MiFlash than before. However I reboot, disable driver signature enforcement or not, always back to teh same thing :(
Thanks for reply, though
 

alchzor

Members
Jan 11, 2017
4
13
Okay, so a bit of an update, I somehow managed to get it to fastboot via deep flash cable.. So it was recognized as a fastboot device and in MiFlash easily, but now I am facing another problem. That is, whatever ROM I try to flash (china, global, developer, whatever I have found for redmi 3 pro) It's just "flashing" on and on. I waited for 40 mins, and it was still the same.
If I try to power up the phone normally, it is stuck at Mi logo.

Any clues what could be done from now on?
 

alchzor

Members
Jan 11, 2017
4
13
I wasn't able, it was only it fast boot, but I somehow solved the issue, and phone is back and alive.

When using MiFlash in fastboot and flashing went on and on, on about 5th try I left it for about 1hour, still no change, then I just pressed off button on phone, while phone still connected, and it jumped to the end, said "flash finished". But not sure what was wrong, still didn't boot up, so this morning I downloaded lastest china stable ROM, and it flashed, phone booted. Unfortunately China, with no google play and such, but now I managed to install TWRP and CM14. It's running smoothly now.

Thank you all very much for replies and help!