[8-16] A possible solution to enabling Swype and Miui to work correctly.

Discussion in 'Bugs' started by InSaiyanOne, Aug 16, 2011.

  1. InSaiyanOne

    Aug 9, 2011
    9
    0
    11
    Firstly, props to yournameshouldbehere from Modaco for an important find (using root explorer to move LatinIME.apk from system/app to your SD card and then back to create a force close enviroment in keyboard settings & fixing permissions) this was great since it helped allow the rom to recreate a "swype" option in the keyboard settings. This was tested on TripNMiui although this may work for other ports/roms so please assist if you can by letting us know if it does actually work (or not). Also, I have not found this solution anywhere else so if it was posted please excuse my post.

    Procedure:
    - Completely uninstall anything swype related.
    - Now run the swype installer, login, download, and install the version of choice, and tap DONE.
    - You should now be at a prompt stating either to enable swype or showing 4 buttons (last two being generate license and finish).
    - Using root explorer, go into the system/app folder and move the latinIME.apk out to your SD card (I put it in the DCIM folder) then IMMEDIATELY move it back.
    - Reboot your phone (don't go into keyboard settings or anything just reboot) into recovery and fix permissions, reboot after it's complete.
    - Now here is where I tried two things. First, go into the Language & Input Settings and OBSERVE ONLY that swype is the current keyboard selected DO NOT GO INTO THE MENU ITSELF!
    - Now go into an app like market or browser and get to where you can type something (like search in market) the keyboard should show up...I didn't swype right away but just manually typed a small word and then swyped the very next word with no issues.

    I've done it two more times to check consistency. Both of the times I got the "select swype" screen after installing swype. Followed the steps and it worked. Great what working together (and no sleep) can do.


    Edit: This possibly could be used to enable other keyboard styles also. Use the steps that create the force close after you install your preferred keyboard and then fix permissions and see if that works.
     

Share Our Site