Oct 11, 2023
Using 14U with xiaomi eu 1.0.9 and rooted.

I am trying AdAway. If works at first but after a few hours or days, it stops working and I see ads. I usually have to reboot.

I tried enabling background auto start and turning off battery saver but no help. I think it just changes the the hosts file so it shouldn't even need to stay running.

I have private DNS off but I didn't think that should matter either

Anyone else notice this?
I know AdAway works in VPN mode on stock Global 14U. I needed to disable battery saver for this service and (probably) enable notifications. To work across reboots also autostart was needed.
no I'm using root mode
I know, so theoretically your problem can be something else

But you should still be able to see if AdAway icon disappears and if it's the case you would know what's the problem.
I've checked and found that it works even when set as 'Battery saver'
I'm not sure about notifications, but many apps running in background used toolbar icon to not be closed in background and needed permissions to 'show notifications' to not be killed, while running in background.

But if it still runs(and have icon in toolbar), but ads start appearing, then you will know it's not the problem with AdAway being closed by system or crashing itself.
It can be some other app (including system services) modifying /etc/hosts file.
Under Linux you could run 'fuser' or 'lsopen' commands in loop to catch such app. I don't have much experience with Android, but I guess that with root there's some alternative for that.
I don't know why it should matter at all if the adaway app gets killed. The hosts file is already changed. It would only affect updates.

I checked /etc/hosts and it has the blocks in there but I still see ads.
Since my phone is operational again and still not rooted I can only recommend to give private dns with ad guard a try, convenient and easy to disable if required, works like a charm!


Sent from my Xiaomi 14 Ultra using Tapatalk