AI Button not working with assistant [9.8.29, Android Q]


Worgen325

Members
Sep 1, 2019
4
5
Hello, I just updated my Mi 9 to 9.8.29 and when I press AI Button nothing happens. I remapped it to open Google search and that is working properly.
 

Dorisnov

Members
Jun 19, 2018
114
30
It certanly works on 9.8.29 but even if I have "Talk to assistant" selected in both press and press and hold, when I press it opens the asistant app and when I press and hold it really opens the "talk to assistant" screen. So, picked the same behaviour for both press and press and hold does different things.

This was solved in a previous version.
 
Last edited:

Worgen325

Members
Sep 1, 2019
4
5
Thanks, it solved it for me.

It certanly works on 9.8.29 but even if I have "Talk to assistant" selected in both press and press and hold, when I press it opens the asistant app and when I press and hold it really opens the "talk to assistant" screen. So, picked the same behaviour for both press and press and hold does different things.

This was solved in a previous version.
That was the reason i ran away from Global to Xiaomi.eu, and it haunts me even on this ROM. But IIRC it got solved on stable.
 
  • Like
Reactions: Mali2

Mali2

Members
Jan 3, 2017
99
30
It certanly works on 9.8.29 but even if I have "Talk to assistant" selected in both press and press and hold, when I press it opens the asistant app and when I press and hold it really opens the "talk to assistant" screen. So, picked the same behaviour for both press and press and hold does different things.

This was solved in a previous version.
And you realy have set Google as default for "Assist & voice input" and "Voice assistant" in Default apps (setting, apps, manage apps)?
 

DinisBC

Members
Jul 8, 2018
6
15
Do any of you have any idea on how I can keep using Google assistant in English while my phone´s language is Portuguese (Portugal)?
 

DinisBC

Members
Jul 8, 2018
6
15
I mean, I can't use google assistant at all if my phone's language is Portuguese even though Google's assistant language is English.
It says the Portuguese (Portugal) language isn't compatible with Google assistant.
26029

26030
 

Dorisnov

Members
Jun 19, 2018
114
30
And you realy have set Google as default for "Assist & voice input" and "Voice assistant" in Default apps (setting, apps, manage apps)?
Yep, I setted Google in both options inside Voice assistance and Google as Assistance and... And AI button works to open the Assistant page but only in hear mode when i press and hold.
 
  • Like
Reactions: Worgen325

Mali2

Members
Jan 3, 2017
99
30
Yep, I setted Google in both options inside Voice assistance and Google as Assistance and... And AI button works to open the Assistant page but only in hear mode when i press and hold.
No idea, my Assistent talks to me after hearing ...
 

Dorisnov

Members
Jun 19, 2018
114
30
No idea, my Assistent talks to me after hearing ...
I've made a video to show what happens with the 3 different options:

In the video you can see that single press or double press opens the Assistant page, not the hearing mode that shows when press and hold.
 

Mali2

Members
Jan 3, 2017
99
30
I've made a video to show what happens with the 3 different options:

In the video you can see that single press or double press opens the Assistant page, not the hearing mode that shows when press and hold.
Wich standard language is activ on your phone?
 

Mali2

Members
Jan 3, 2017
99
30
Spanish. I've tryied changing to English (NA) and same. Whats your device?
Mine ist german. Portouguese seems with issue, maybe spanish too? DinisBC have just reported as bug.

Update: i confirm, If i set language to spanish (espana), Assistent don't answer after hold AI button and speak.
 
Last edited:

Dorisnov

Members
Jun 19, 2018
114
30
Mine ist german. Portouguese seems with issue, maybe spanish too? DinisBC have just reported as bug.
Is not the same problem. So when you press the AI button the little assistant windows opens in listening mode? Not the whole assistant? I think I'm gonna make a bug post too.
 
  • Like
Reactions: Worgen325 and Mali2

komatoza

Members
Aug 16, 2019
7
5
Same here with Greek language on the phone. Assistant is set to English but I can't enable it to listen. If set the phone to English assistant work.

Στάλθηκε από το MI 9 μου χρησιμοποιώντας Tapatalk
 
  • Like
Reactions: Mali2

Mali2

Members
Jan 3, 2017
99
30
Is not the same problem. So when you press the AI button the little assistant windows opens in listening mode? Not the whole assistant? I think I'm gonna make a bug post too.
To clear: in german, if i press the button the whole assistent opens. If i press and hold the button, the little window in listening mode opens.
 
  • Like
Reactions: Dorisnov

Dorisnov

Members
Jun 19, 2018
114
30
So we all have this same problem. Since the option is "Talk to assistant" I think this behaviour is not correct.
 
  • Like
Reactions: Mali2

Worgen325

Members
Sep 1, 2019
4
5
I'm afraid we have to wait until update, same issue occured on global stable and it was only fixed by update.