Apps2SD not working

Discussion in 'Bugs' started by vikramjatt11, Jan 19, 2011.

  1. vikramjatt11

    Jan 18, 2011
    8
    0
    11
    Update: I just typed the command "a2sd partlist" in terminal emulator, and it shows this ROM does not support ext2, ext3, or ext4. So that means no A2SD on MIUI. Shame really, was such a good ROM.
    -----------
    Original post:
    I tried out the MIUI ROM yesterday after I read a thread in the general section about how great it is. One thing that isn't working for me is the Apps2SD. My current ext size is 912Mb, and it is currently ext4. When I go to "menu > settings > system > SD card settings" I get the image below:
    http://i53.tinypic.com/2b420z.jpg
    http://i54.tinypic.com/10e1s21.jpg
    http://i56.tinypic.com/2ajaqyu.jpg


    The phone states my "A2SD+" total space is 0.00B (even thought I just formatted my SD card, and made ext-size = ~912Mb) and the available space is 0.00B.

    I have read that in some ROMs the available space is sometimes the wrong value here, so I ran Apps2SD thru RA-recovery, everything went successful. But when I restart my phone, I still get the notification that I am running low on storage, meaning it did NOT work after all.

    Another user told me this just recently stopped working in the latest update, and so I am reporting it in the bugs section. If it can be fixed in the next update, would be great.
     
  2. w4rheart

    w4rheartMembers

    Jan 17, 2011
    6
    0
    11
    does work for me.

    MIUI 1.14 HTC Desire
     
  3. chris_abr

    chris_abrMembers

    Nov 27, 2010
    56
    0
    16
    it shows on my phone as it should show, all 900 and something mb of space, but the app2sd doesn't seem to work.
    I mean all of the apps seem to be installed on phone memory.
    I have barely 100 apps, and the space's already full, I can't install anymore apps. even though the ext partition has over 800 mb free..

    so for now I switched to a different rom, will check it in next few releases, hopefully it'll be fixed.
     
  4. Mish

    MishMIUI Android Staff

    MIUI 1.1.14 on Nexus One

    [​IMG]
     
  5. sat182

    sat182Members

    Dec 6, 2010
    1
    0
    11
    I confirm A2SD+ not work in my Milestone; always says unavailable in total&available space.
    Anyone can say with a Milestone as it did correctly detect the ext3 partition?
     
  6. chris_abr

    chris_abrMembers

    Nov 27, 2010
    56
    0
    16
    how did you format the memory card?
    and for me- it seems as it is sort of working..
    I mean the ext is getting filled up, but it's like that was just a copy of what there is on an internal memory.
    basicaly when I install an app, its filling the space up on an internal memory, but on ext aswell..
    which is weird.
    someone suggested that it changed on restart, that the internal memory will "refresh" I restarted phone, and nothing happens, same thing.

    any ideas?
     
  7. Papel

    PapelMembers

    Jan 24, 2011
    1
    0
    11
    from the Terminal app, or ADB commands.
    Its best to use ext3 on your SD Card.

    DT Commands:
    *a2db shell ("su" in Terminal Emulator)
    *a2sd check
    *a2sd reinstall
    reboot
    *a2sd zipalign
    *a2sd cachesd
    reboot

    On my N1 work fine after these commands

    Sorry for my english, I'm italian :D
     

Share Our Site