Black screen on call (when phone is in the pocket)

Discussion in 'Bugs' started by skuum, Apr 11, 2011.

  1. skuum

    skuumMembers

    Apr 7, 2011
    36
    0
    16
    Is it a known issue?

    I only get the black-screen when my phone is in my pocket and im getting a call. (or when anything covering the screen before the call)
    So i have to click on the button to see the caller..

    If my phone is on the table, i'll see the caller immediately..


    Its like when during a call, you put the phone to your ear and it blacks out.. and when you remove the phone it lights..
     
  2. fusingblackrose

    Nov 28, 2010
    520
    2
    55
    That's the purpose. It blacks out because you don't need to see it when it's up to your ear, and when you pull it away from your ear, it lights up, so you can see what you need to do with it, until you put it back on your ear, where it blacks out again. Get it?
     
  3. skuum

    skuumMembers

    Apr 7, 2011
    36
    0
    16
    Lol, i know dude.. That was not my question duo :) That part was just an example for my problem..

    The thing is... If i have my phone in my pocket.. and someone calls me..

    I pick up the phone and its all black, the screen is off.. It keeps ringing
    and i dont know whos calling me.

    I need to press the power-button se see whos calling...

    Normally after i pick up the phone from my pocket, it should light up so i can see whos calling...

    However, if the phone is laying on a table, nothing blocking the screen... it lights upp like it should be..

    Sorry for the misunderstanding :)
     
  4. ZeroBarrier

    Nov 24, 2010
    249
    0
    38
    Las Vegas, NV
    It sounds as if you have the "enforce proximity sensor" setting enabled and this is causing the proximity sensor to be enabled as soon as you receive a call, instead of waiting to enforce it after answering the call. I believe the problem you are having might be that perhaps you are covering the proximity sensor with part of your hand. This happens to me on occasion.

    You should verify the location of the proximity sensor on your device, in a well lighted environment you should see a faint circle in the upper portion of the glass covering your screen near the earpiece speaker. Next time you get a call and pull it out of your pocket, remember to keep any part of your hand away from that area.

    Let me know if this helps you.
     
  5. skuum

    skuumMembers

    Apr 7, 2011
    36
    0
    16
    Never heard of 'proximity sensor' setting, but it sure was enabled...

    I disabled it and works fine now :) (I kept the range sensor enabled duo)

    Thanks
     

Share Our Site