In Progress Broken Root

Discussion in 'Bugs' started by quaff, Apr 27, 2012.

  1. quaff

    quaffMembers

    Jun 23, 2011
    16
    1
    13
    Root access was working just fine a couple of days ago (it was still working after I updated to 2.4.20), and now for some reason, when I try to access TitaniumBackup just now, it says it can't access "/xsystem/bin/su"

    I tried replacing BusyBox, but BusyBox Installer couldn't get root access. I tried downloading the SuperUser app, and that still can't get root access in TitaniumBackup. I've tried running fix permissions from recovery.

    Anyone have this same problem? or know how to fix it?
     
  2. iBotPeaches

    iBotPeachesScript Gatekeeper

    Oct 31, 2011
    3,811
    1,114
    335
    Kansas
    This is on our ROM? I'm 100% our updater scripts chmod the needed files.
     
  3. Have you updated to 2.4.27?
     
  4. Rickard Olsson

    Apr 27, 2012
    11
    0
    11
    Male
    I am having the same problem with "broken root" when trying to access Titanium backup,
    on my Galaxy S2
     
  5. quaff

    quaffMembers

    Jun 23, 2011
    16
    1
    13
    I just updated to 2.4.27 just now, I have the same issues. The only way I can fix this is if I do a wipe. Trying my best not to do that :/ I think i may have used TitaniumBackup to freeze something I shouldn't have, anyone know what the miui superuser app is called? and how to unfreeze it manually?
     
  6. Rickard Olsson

    Apr 27, 2012
    11
    0
    11
    Male
    Still having broken root, updated to 2.6.1 today via clean wipe/factory reset.
    Titanium still says broken root! (SGS2)
     
  7. Stephen Brace

    Feb 29, 2012
    98
    18
    18
    Male
    If you install Siyah Kernel and ExTweaks, you can remove and reinstall root. This may fix your problem. You can find Siyah kernel here - http://gokhanmoral.com/ and Extweaks on Play Store
     
  8. shicomm

    shicommMembers

    Nov 26, 2011
    78
    6
    18
    Have had this issue also on my milestone running the miui GB.
    I deleted and reinstalled both superuser and titanium ; after a couple of tries it worked again.
    Unsure if this still works with ICS...
     
  9. Rickard Olsson

    Apr 27, 2012
    11
    0
    11
    Male
    Installed suggested kernel and ExTweaks, removed root and installed root again and now it works. Thanks!!!
     

Share Our Site