Can't charge the battery

Discussion in 'Bugs' started by Little_Devil, Sep 13, 2011.

  1. Little_Devil

    May 22, 2011
    101
    0
    26
    I don't know if it is a bug from this rom or something else, but my battery went empty and now I am unable to recharge it, I am using HD2 on 1.9.9


    plz help, what to do ??
     
  2. Ewors

    EworsMembers

    Jul 3, 2011
    47
    0
    16
    How cant u charge it?
    Doesn´t the notification LED shine?
    Did you check the USB cable if its not broken?
     
  3. Little_Devil

    May 22, 2011
    101
    0
    26
    nope the LED doesn't shine,, and yes I checked the USB Cable and the same,, I don't know what the problem is, hope it has nothing to do with the device itself :(
     
  4. Ewors

    EworsMembers

    Jul 3, 2011
    47
    0
    16
    And does the connector goes in correctly? I mean, dont you have any problems with connecting the cable into the port?
    Another idea, If you look inside of the port, theres small 5mm long board in the center of it. Doesnt it look damaged or broken?
     
  5. cyberstoic

    cyberstoicMembers

    Apr 20, 2011
    209
    1
    40
    Psychologist
    The Windy City
    Have you tried on another port on the computer or a different charger? Sometimes they go bad :( My charger just stopped working this morning and luckily I had a data cable for the computer to charge it
     
  6. Little_Devil

    May 22, 2011
    101
    0
    26
    thanks for the suggestions I tried what you said , but still no luck. I bought universal battery charger, charged the battery and seems like it is charged, when I first inserted it in the device it turned on and showed 76%, but just after 5 min of using the device ( just managing and editing some contacts ) it went down to 45 and then the device turned off. I redid the same for the battery, and inserted it again after about an hour, but the device didn't turn on.

    so is this a battery problem, rom problem or maybe my device died :(
     
  7. Ewors

    EworsMembers

    Jul 3, 2011
    47
    0
    16
    I dont think that its software problem...battery problem? try to charge ur device with another battery.. and at last like u said, ur device died? I cant say that definately but I hope that its false :/
     
  8. cyberstoic

    cyberstoicMembers

    Apr 20, 2011
    209
    1
    40
    Psychologist
    The Windy City
    I would get another battery, as that is what it sounds like. In the short term, charge it as best you can, boot into recovery and wipe the battery stats. It is under "advanced" in cwm (don't remember where it is in amon_ra recovery). It probably won't work, but perhaps it might. I just peeked at amazon.com and you can get aftermarket batteries for $3.95 and HTC batteries for 7.95. It is cheap enough to see if that might fix it.
     
  9. Little_Devil

    May 22, 2011
    101
    0
    26
    @Ewors @cyberstoic: thanks for you replays , freind of mine has HD2 too, I tried his phone's battery on my HD2 and the device worked perfect, so I think my battery is dead, I will try to get a new one soon.

    @cyberstoic: by the way I can't boot into recovery too with my current battery, although I charged it for about 3 hours.
     

Share Our Site