Can't Connect To Wi-fi After System Wipe


Dec 5, 2016
10
0
11
#1
I wiped system by mistake while wiping Cache/Data to install new ROM using TWRP. I managed to flash another ROM using TWRP but now I can't have any WI-FI connection. The device can identify networks but after I enter the password (double checked if it was the correct one) it doesn't pass the authentication part.

Any advices? I'm trying to flash the Global stable .img to see if it works.

Thanks in advance
 
Aug 31, 2016
297
131
67
#2
I think that by wiping /system, you also wiped your /efs partition, which I think that, besides your IMEI, contains info related to yout WiFi MAC address. Without that, you will not be able to connect to WiFi nor cellular networks.

Can you connect to your cellular provider? Can you make/receive calls or connect to 3G/4G?

Also: do you have a TWRP backup of your EFS partition? You'll need that to be able to restore it...
 
Dec 5, 2016
10
0
11
#3
I think that by wiping /system, you also wiped your /efs partition, which I think that, besides your IMEI, contains info related to yout WiFi MAC address. Without that, you will not be able to connect to WiFi nor cellular networks.

Can you connect to your cellular provider? Can you make/receive calls or connect to 3G/4G?

Also: do you have a TWRP backup of your EFS partition? You'll need that to be able to restore it...
I can receive and make calls and also connect to 3G/4G. No I don't have any backups of the efs partition.

Is there a way to check if i really wiped efs partition aswell?
 
Aug 31, 2016
297
131
67
#4
I think if you have cellular functions, you haven't lost your /efs after all...

Just out of curiosity, can you check that you have a valid WiFi MAC address (you can check it on Settings > About phone > Status; don't post it here!)?
 
Dec 5, 2016
10
0
11
#5
I think if you have cellular functions, you haven't lost your /efs after all...

Just out of curiosity, can you check that you have a valid WiFi MAC address (you can check it on Settings > About phone > Status; don't post it here!)?
Yes, I do have a MAC Address for WI-FI, only the IP Address is Unavailable. IMEI is there aswell.
 
Aug 31, 2016
297
131
67
#6
If you have a MAC address and cellular connectivity, then you still have your EFS partition. The problem is somewhere else...

Could it be a problem with that particular WiFi network? Did you try other ones?
 
Dec 5, 2016
10
0
11
#7
If you have a MAC address and cellular connectivity, then you still have your EFS partition. The problem is somewhere else...

Could it be a problem with that particular WiFi network? Did you try other ones?
I didn't try with others yet, but before I wiped the system, I was able to connect to this network, and I am able to connect to this particular network with other devices.
 
Aug 31, 2016
297
131
67
#8
Just to be sure, try to connect to other networks, see how that works out. If you can successfully connect to other networks, it might well be a temporary problem with this particular network.

Also: on which ROM are you? Which version?
 
Dec 5, 2016
10
0
11
#9
Just to be sure, try to connect to other networks, see how that works out. If you can successfully connect to other networks, it might well be a temporary problem with this particular network.

Also: on which ROM are you? Which version?
I have xiaomi.eu ROM version 7.1.5 but I have already installed other custom ROMs and no success on the WI-FI connection.
 
Dec 5, 2016
10
0
11
#10
UPDATE: I have flashed the Global Stable and the problem still presists. I have tried other networks as well and it still doesn't connet. It gives me "Authentication problem" everytime.
 
Jan 15, 2017
2
0
11
#13
Hi there,

I had the same problem and I found a solution which I'm not allowed to link on XDA. The link extension is /mi-5/help/wifi-connectivity-problem-t3517777

Basically, the solution is to set new MAC-addresses in /etc/firmware/wlan/qca_cld/wlan_mac.bin .

1. Disable wifi
2. Edit the file at /etc/firmware/wlan/qca_cld/wlan_mac.bin (I used ADB and a command line editor, but you can also use the file explorer app with root permissions)
3. The file has 3 lines
Code:
Intf0MacAddress=<12 hexadecimal  characters>
Intf1MacAddress=<Intf0MacAddress + 1>
END
Save this info somewhere in case this doesn't work. Then generate a new MAC-address (Google knows how). and put that as the first line. The second line should be the first address + 1.
4. Save, verify your changes stuck, and reboot.
5. Profit!

If this works for you, head on over to XDA to thank the guy who made the original post.
 
Dec 5, 2016
10
0
11
#14
Hi there,

I had the same problem and I found a solution which I'm not allowed to link on XDA. The link extension is /mi-5/help/wifi-connectivity-problem-t3517777

Basically, the solution is to set new MAC-addresses in /etc/firmware/wlan/qca_cld/wlan_mac.bin .

1. Disable wifi
2. Edit the file at /etc/firmware/wlan/qca_cld/wlan_mac.bin (I used ADB and a command line editor, but you can also use the file explorer app with root permissions)
3. The file has 3 lines
Code:
Intf0MacAddress=<12 hexadecimal  characters>
Intf1MacAddress=<Intf0MacAddress + 1>
END
Save this info somewhere in case this doesn't work. Then generate a new MAC-address (Google knows how). and put that as the first line. The second line should be the first address + 1.
4. Save, verify your changes stuck, and reboot.
5. Profit!

If this works for you, head on over to XDA to thank the guy who made the original post.
Hey, it really worked :D
Thank you Ublah for getting the post, and especially thanks to the dude who discovered it. I will personally thank him on his original thread.