Fastboot can't detect Mi Note 10


Dec 8, 2020
Hi, everyone,

I'm having some problems with my Note 10.

I intended to install the global version rom, coming from european.

I used XiaomiTool V2 to automate the process.

At the end of the flashing process, the program returned an error about sideloading, and it aborted.

Then I closed the app, and rebooted the phone: it turned out I'm on global, with bootloader unlocked.

Now I'd like to lock the bootloader back, using "Fastboot oem lock", but Fastboot can't detect the phone (ADB can).

I tried on Mac, Linux and Windows, and I've the same problem with all three.

Is there anything I can do? Maybe flash a new bootloader in some way? Maybe rooting the device?

Am I screwed forever?

Thank you for your time.

[EDIT. 1] I managed to properly install the drivers (both for file transferring and recovery mode) for my phone on a Windows machine running the driver installer that comes along Mi Unlock Application.

In my drivers list appears "ADB device" , or something like that.

The problem with fastboot persists, though.

[EDIT. 2] I tried to use XiaomiFlashTool, but when trying to install the drivers the program stops and returns an error.

[EDIT. 3] I manually installed the proper fastboot drivers included in the Mi Unlock folder mentioned above, but it returns "Error Code 10", and the entry "Android Bootloader Interface" shows with a yellow triangle on Windows Device Manager.

[EDIT. 4] Mi PC suite wasn't able to detect my phone either, then I found out on the web that is an obsolete application and installed the translated chinese version "mi phone assistant", still under active development. It recognized the device and let me flash the global rom again, via recovery, successfully this time (I tried to flash eea rom, but it didn't let me). Still, fastboot can't detect my device, adb can.
If you know any app that lets flash via recovery non global roms that would be perfect.
Last edited: