Having Trouble Rooting And Installing Hermes

Discussion in 'Xiaomi Redmi Note 2' started by moshiachnow, Mar 8, 2016.

  1. moshiachnow

    Jul 4, 2014
    18
    1
    13
    Male
    I have a Redmi Note 2 that was (and is) running the latest stable ROM from miui.com. I wanted to root it and install the ROM from here. I followed the instructions (sideloading the recovery.img, rebooting to recovery and installing the two zip files). But the phone didn't like the zip files and said they were corrupt. I tried a couple of times. Finally I went back to the miui.com ROM.

    Can anyone suggest what the issue might be and help me get the ROM installed?
     
  2. acestars

    acestarsMembers

    Jan 9, 2016
    37
    9
    20
    Male
    Install twrp using fastboot after that reboot directly to recovery using power button + volume up. Install "super su" and remove file "/system/recoverygfrom-boot.p" using file manager inside twrp.

    Sent from my Redmi Note 2 using Tapatalk
     
  3. Etienne_NL

    Etienne_NLMembers

    Jan 2, 2016
    11
    2
    15
    Male
    Hijacking this post as I am having the same problem.

    2015CP2377 running Miu global 7.1 Stable 7.1.3.0(LHMMICK
    Tried to flash using fastboot and recovery.
    - miflash gives a device /rom mismatch
    - recovery gives the corrupt zip error.
    - spflash does not recognise the phone

    If installing twrp can solve it, can anyone guide me through how to install twrp?

    Your help is highly appreciated.
     
  4. Android_new

    Mar 16, 2016
    5
    1
    13
    How to Root and Unroot Redmi Note 2 Without PC

    Hi
    I've been following the instructions on how to root the Redmi Note 2 following these instructions:
    h tt p: // xiaomitips. com / guide/ how-to-root-and-unroot-redmi-note-2 /

    I get all the way to step 9 successfully

    Step 9 – Once you are in the main page of TWRP, you’ll see several menus like Install, Wipe, Backup, Restore, Mount, File Manager, Advanced and Reboot. Tap on Reboot >System. In the next page TWRP will ask you to install SuperSU which will root your device. Simply swipe the slider to the right to confirm SuperSU installation which means rooting your device.

    Everything in green works fine - it then reboots onto the homescreen - there is no next page TWRP - so I don't get to the installation of SuperSU bit.

    I've gone back into to Reboot in Recovery mode and the first two screens of TWRP - just not the SuperSU screen - where am I going wrong?

    Thanks!
     
  5. Xerxes

    XerxesMembers

    Mar 15, 2016
    2
    2
    15
    Male
    #5Xerxes,Mar 16, 2016
    Last edited: Mar 16, 2016
    also in the same boat running Miu global 7.1 Stable 7.1.3.0(LHMMICK), essentially what i wind up with is rom mismatch/zip error. anyone figure it out?

    edit: found some indonesian tutorial on youtube on how to get root access and trwp using Kingroot on specifically (7.1.30 LHMMICK) . Is that a good option? sorry, i just transitioned from iOS so i'm clueless about rooting and stuff.
     
  6. Etienne_NL

    Etienne_NLMembers

    Jan 2, 2016
    11
    2
    15
    Male
    #6Etienne_NL,Mar 16, 2016
    Last edited: Mar 16, 2016
    Got it solved by reinstalling the USB drivers.

    Downloaded Vcom Drivers from this link.
    forum.androidurdu.net/showthread.php?tid=198
    You have to create an account and login, respond and download from the 1st post.

    Via below:
    androidurdu.net/install-working-twrp-2-8-7-0-on-redmi-note-2-mt6795-with-root-or-without-root-guide/#sthash.qxtjtiKN.VBenYgnG.dpbs

    Used SPFlash and below fastboot rom.

    Downloaded the Miu 6 (China) V6.7.11.0.LHMCNCH stable verison here:

    54.243.194.135/thread-173426-1-1.html

    Finally Miu6 worked and I could flash the hermes eu multi Miu7 again with flashboot.

    Hope it works for you guys.
     
  7. Etienne_NL

    Etienne_NLMembers

    Jan 2, 2016
    11
    2
    15
    Male
  8. Athis

    AthisMembers

    Mar 13, 2016
    9
    5
    13
    Try to root your phone with Root Genius or KingoRoot. Then install flashify on your phone and give it root access. Get TWRP image file and flash it through flashify.
    You should be able to install successfully TWRP. Then with TWRP it would not be hard to flash the desired ROM.
     
    Android_new likes this.
  9. Etienne_NL

    Etienne_NLMembers

    Jan 2, 2016
    11
    2
    15
    Male
    Tried all of that before and failed.

    Think all has to do with having the Miu7 global stable rom installed, nothing gets done if you have that one on your Note 2.

    But am a happy camper, mine is sorted.
     
    Athis and Android_new like this.
  10. Xerxes

    XerxesMembers

    Mar 15, 2016
    2
    2
    15
    Male
    That worked for me :)
     
    Athis and Android_new like this.

Share Our Site