HD2 audio over speaker stops working after using voice command to call over Bluetooth

Discussion in 'Bugs' started by KevlarTheGreat, May 25, 2011.

  1. KevlarTheGreat

    Apr 7, 2011
    15
    0
    11
    Hardware: HTC HD2 TMOUS 1024
    ROM: 1.5.20 Beta 7 with English Pack

    Short Description:
    HD2 audio over speaker (and 40mm jack) stops working after using voice command to call over Bluetooth

    Steps to reproduce problem:
    1) Connect bluetooth headset (mine is a Jawbone Icon)
    2) Hold down the button on the bluetooth headset to initiate voice command.
    3) Call someone by saying "Call <Person Name>"
    4) After the call is hung up by any means, turn off the headset.
    5) No audio on the phone (speaker or 40mm jack) will work anymore, only bluetooth.
    6) Reboot phone to make the speaker and 40mm headphone jack work again.

    I hope this helps and thanks so much for these great ROMs.
    Kevlar
     
  2. KevlarTheGreat

    Apr 7, 2011
    15
    0
    11
    Just another little note. It's all audio that fails to work after this, not just calls. Ringtones, Music, etc. They only play on the headset. My uneducated guess is that the phone forgets to mux the audio back to its previous state after a bluetooth headset is used with voice dialing, then disconnected.

    Maybe this only occurs with headsets that support A2DP?
     
  3. KevlarTheGreat

    Apr 7, 2011
    15
    0
    11
    I might have found a solution to this. The ROM from this thread uses the same kernel as MIUI for HD2. Is anyone with an HD2 willing to try it? If I weren't so busy at work, I'd try to figure out how to do it, but I don't know what to do right now... It sounds like it may fix a bunch of our other audio related issues as well. For example, our navigation audio gets so low you can't hear it if you try to also play music or something..., etc..
    http://forum.xda-developers.com/showpost.php?p=12892970&postcount=3829
     
  4. KevlarTheGreat

    Apr 7, 2011
    15
    0
    11
    It feels like I'm having a great conversation with myself. :) Anyhow, that fix doesn't work with MIUI unfortunately. So we are still broken...
     
  5. kcfong2

    kcfong2Members

    Aug 4, 2011
    1
    0
    11
    KevlarTheGreat: Did you ever get any useful response to your (our) problem, either here or on XDA?
     
  6. KevlarTheGreat

    Apr 7, 2011
    15
    0
    11
    Nope. I've tried running CM7 and it has the same problem. Much older android builds didn't have this. Problem. It seems like maybe it started to occur when they fixed robot voice.
     

Share Our Site