Help/stuck: phone reboots after lockscreen/authentication


E-OSy

Members
Jul 14, 2020
11
13
Hello Today I played a little bit with AppManager (root tool for app permissions and disabled alot for gms ) suddenly it restarts. And now I'm stuck on the lockscreen. As soon as i enter my pin I see my launcher (stock miui launcher) for 1-2sec and than it reboots again to the lockscreen.
But looks like a soft reboot instead of a full phone shutdown and reboot

Please I need Help I cant use my phone and I need it for work ! Factory Reset is the very last option for me

I have the latest Miui 12 from xiaomi.eu for Mi9T, TWRP, Magisk, Xposed
I didn't try a lot at this time, as I'm still confused what happend
I tried to dirty flash the same rom but nothing changed
I tried with and without magisk
I tried to replace the miui lauchner with the only other one I have instaled (poco). It worked to switch them but it will still reboot
I deleted gms and its data
I deleted package-restrictions.xml + dirty flash

I think the problem is AppManager blocked the hole system to use some gms functions and what ever gets called after the lockscreen authentication

And I saw this: [HOWTO] Enable adb logcat on first boot without authentication (debugging boot loops)
Because, I cant get my logs or atleast there are empty (logcat and last kmsg)
so the first step is, how can I diagnose the couse of the soft reboot ?

Thank you for reading and any help !