Help with Mi Mix 2


N0xtrum

Members
Oct 28, 2020
6
15
Hi,


After some time thinking about giving my Mi Mix 2 a new lease on life, today I decided to unlock it and install a custom ROM.

I used the Xiaomi app to unlock it, it took a bit, but finally, success. But that's where the problems begin.

I try first with pixelexperience rom for Chiron

I follow the steps but nothing works.
.\fastboot.exe devices
eed1d02e fastboot

It's OK.
.\fastboot.exe oem unlock
FAILED (remote: 'Token Verify Failed, Reboot the device
') fastboot: error: Command failed

And reboot the device to fastboot
.\fastboot.exe getvar all
(bootloader) crc:1
(bootloader) anti:1
(bootloader) DP:0x0
(bootloader) token:zTKyJe2yLrZNq0tmK8o3Kt55DZY=
(bootloader) board_version:3.2.0
(bootloader) unlocked:yes
(bootloader) off-mode-charge:0
(bootloader) charger-screen-enabled:0
(bootloader) battery-soc-ok:yes
(bootloader) battery-voltage:3723
(bootloader) version-baseband:`¶³ƒ
(bootloader) version-bootloader:`¶³ƒ
(bootloader) variant:MSM UFS
(bootloader) partition-type:cache:ext4
(bootloader) partition-size:cache: 0x10000000
(bootloader) partition-type:userdata:ext4
(bootloader) partition-size:userdata: 0xD247FB000
(bootloader) partition-type:system:ext4
(bootloader) partition-size:system: 0x140000000
(bootloader) wcnss:1
(bootloader) serial:eed1d02e
(bootloader) product:chiron
(bootloader) max-download-size:536870912
(bootloader) kernel:uefi
all:
Finished. Total time: 0.014s

This aparently it's OK but when i try:

.\fastboot.exe flash recovery .\twrp-3.2.1-0-chiron.img

Do noting...OK, maybe a twrp issue, i test with a new one version and same issue.

.\fastboot.exe boot .\twrp-3.2.1-0-chiron.img Sending 'boot.img' (26360 KB)
FAILED (Write to device failed in SendBuffer() (no link)) fastboot: error: Command failed

platform-tools>fastboot.exe flash recovery recovery.img
Warning: skip copying recovery image avb footer (recovery partition size: 0, recovery image size: 26185728).
Sending 'recovery' (25572 KB) FAILED (Write to device failed (Invalid argument)) fastboot: error: Command failed

This is the unique concrete error i got.

So i tried even with the original boot.img

miui_MIMIX2Global_V12.0.1.0.PDEMIXM_64006b3102_9.0>fastboot.exe boot boot.img
Sending 'boot.img' (18805 KB)

No response.

I think the memory could be damaged, or maybe I'm missing something. Any ideas? I'm totally lost now.

Thanks in advance
 

Attachments

  • IMG_20231202_213442.jpg
    IMG_20231202_213442.jpg
    217.1 KB · Views: 80
  • IMG_20231202_213504.jpg
    IMG_20231202_213504.jpg
    227 KB · Views: 85
  • IMG_20231202_213514.jpg
    IMG_20231202_213514.jpg
    171 KB · Views: 224
I tried to flash with MiFlash 2023.04 with the original global rom and never ends flashing and logs don't show erros..

1701552862389.png
 
Incredible. After hours trying.. i left the device ouf of battery, made a full charge and...

.\fastboot.exe flash recovery .\PixelExperience_Plus_chiron-13.0-20230812-0831-OFFICIAL.img
Warning: skip copying recovery image avb footer (recovery partition size: 0, recovery image size: 27234304).
Sending 'recovery' (26596 KB) OKAY [ 0.766s]
Writing 'recovery' OKAY [ 0.238s]
Finished. Total time: 1.013s

xDD