How to disable automatic night/reading mode - Mi 11 Ultra


djaj85

Members
Oct 14, 2021
12
15
Hi,

I'm running the latest miui.eu ROM on my Mi 11 ultra and I've noticed that the phone automatically turns on reading/night mode during the evenings. I want to disable this, however the issue is that this is not enabled in the settings.
Display is set to Light mode.
Brightness level is set to auto.
Color scheme is set to auto.
Reading mode is off.
Anybody have any ideas on how to resolve this issue?
Thanks in advance.
 

bUll1t_M3

Members
Mar 14, 2016
4
13
Hi. Finally Somebody with The Same issue. I own a Mi10 and a Mi11 both running The Same MIUI Version.

When the clock says its nicht, The Screen of The mi11 Turns yellow. The one on the Mi10 stays normal. If i change the clock manually to daytime it Turns normal again. But Reading Mode is turned of. If i enable IT, IT increases the strength of The tinting
 

djaj85

Members
Oct 14, 2021
12
15
Hi. Finally Somebody with The Same issue. I own a Mi10 and a Mi11 both running The Same MIUI Version.

When the clock says its nicht, The Screen of The mi11 Turns yellow. The one on the Mi10 stays normal. If i change the clock manually to daytime it Turns normal again. But Reading Mode is turned of. If i enable IT, IT increases the strength of The tinting
Hey,

I did manage to solve this issue with help from another user here on the forum.

Issue occurs because MIUI has a separate reading mode on top of android night light, but the android one is hidden, so when you restore from another device when you set up the phone, it gets enabled with no way to turn it off, because it's hidden,

The following commands executed through adb should solve your issue:

adb shell settings put secure night_display_activated 0

adb shell settings put secure night_display_auto_mode 0
 

bUll1t_M3

Members
Mar 14, 2016
4
13
Hey,

I did manage to solve this issue with help from another user here on the forum.

Issue occurs because MIUI has a separate reading mode on top of android night light, but the android one is hidden, so when you restore from another device when you set up the phone, it gets enabled with no way to turn it off, because it's hidden,

The following commands executed through adb should solve your issue:

adb shell settings put secure night_display_activated 0

adb shell settings put secure night_display_auto_mode 0
Man, you are great. Thank you so much. Finally i dont have to throw away my Mi11.
THANKS !!!
 

Zanpacto

Members
Apr 17, 2022
1
3
Hey,

I did manage to solve this issue with help from another user here on the forum.

Issue occurs because MIUI has a separate reading mode on top of android night light, but the android one is hidden, so when you restore from another device when you set up the phone, it gets enabled with no way to turn it off, because it's hidden,

The following commands executed through adb should solve your issue:

adb shell settings put secure night_display_activated 0

adb shell settings put secure night_display_auto_mode 0
i created an account just to thank you, so
thank you friend
 

terlaps

Members
May 14, 2022
1
3
Hey,

I did manage to solve this issue with help from another user here on the forum.

Issue occurs because MIUI has a separate reading mode on top of android night light, but the android one is hidden, so when you restore from another device when you set up the phone, it gets enabled with no way to turn it off, because it's hidden,

The following commands executed through adb should solve your issue:

adb shell settings put secure night_display_activated 0

adb shell settings put secure night_display_auto_mode 0
Additions links that might help (at least they helped me) with the execution of the commands above.
1.https://www.xda-developers.com/install-adb-windows-macos-linux/#adbsetuplinux
2.https://github.com/appium/appium/issues/13802#issuecomment-587802222
3.https://itsfoss.com/fix-error-insufficient-permissions-device/
 

Zivaie

Members
Aug 25, 2022
1
3
Hey,

I did manage to solve this issue with help from another user here on the forum.

Issue occurs because MIUI has a separate reading mode on top of android night light, but the android one is hidden, so when you restore from another device when you set up the phone, it gets enabled with no way to turn it off, because it's hidden,

The following commands executed through adb should solve your issue:

adb shell settings put secure night_display_activated 0

adb shell settings put secure night_display_auto_mode 0
Hello, how do i start with the commands, i have struggled with my phone i cant seem to find a solution to disable night light
 

djaj85

Members
Oct 14, 2021
12
15
Hello, how do i start with the commands, i have struggled with my phone i cant seem to find a solution to disable night light
Hey, refer to post #7 for details on how to execute adb commands. Additionally, there are plenty of YouTube tutorials available for step by step instructions.
 

synapsespeed

Members
Oct 18, 2022
1
3
Hey,

I did manage to solve this issue with help from another user here on the forum.

Issue occurs because MIUI has a separate reading mode on top of android night light, but the android one is hidden, so when you restore from another device when you set up the phone, it gets enabled with no way to turn it off, because it's hidden,

The following commands executed through adb should solve your issue:

adb shell settings put secure night_display_activated 0

adb shell settings put secure night_display_auto_mode 0
Thanks man, it worked flawlessly on my MI 11T.
PS - I also got an account just to be able to thank you! :D
PPS - @xiaomi_devs I really hope for an update that contains these settings in the UI !