Installing Magisk and Play Integrity Fix

Hello, i install today PIF, but still not work wallet. I test integrity and here is result
Build fingerprint: Xiaomi/aristotle_global/aristotle:12/SP1A.210812.016/V14.0.6.0.TMFMIXM:user/release-keys
Brand: Xiaomi
Device: aristotle
Model: 2306EPN60G
Wipe Cache for Wallet. Check in Wallet Settings, Payment method, what exactly it complains about


  • IMG_20240518_210743.jpg
    272.5 KB · Views: 78
Cache from wallet is clear, In payment method is phone has no security requiments. I try uninstal and instal Xiaomi eu module and still not work. I try clear cache and data from wallet and still not work.
  • Like
Reactions: Jacometto
Thanks for the clarification - weirdly enough, I never installed Magisk. I received PIF updates right from the update menu (system settings), there would be a message pointing me towards the download of the latest apk. This is no longer happening. So I followed your link (thank you again) and installed the latest EU module, which seems to be the same thing. Now I'm back at DEVICE_INTEGRITY (was at basic before) - but wallet is still complaining. I'll just give it a day and try after wiping cache and rebooting a few times. I'll report back. Any idea why they stopped shipping the fix via OTA?
Yeah, 'injector' is the latest XiaomiEUModule_2024.05.15.apk

But PIF = Play Integrity FIX and cannot work without Magisk, and it's not an app

If you mean (Simple) Play Integrity Check(er) apps, so SPIC or PIC - they are just checkers to check/test your Play Integrity (you don't uninstall them but you can still use them to test Play Integrity)

If you mean something else, pls provide a scrinshot
  • Like
Reactions: Jacometto
@kenhill If you did not update your ROM recently, I think it is linked to this announcement

  • Like
Reactions: kenhill
@kenhill If you did not update your ROM recently, I think it is linked to this announcement

Hi JiaiJ
Something strange happened with Wallet certification. I also confirmed that even Play Integrity certified with the latest EU.apk my Google Payment stopped to work today. None Clean or reboot solves.
@kenhill If you did not update your ROM recently, I think it is linked to this announcement

Gosh darn - looks like this refers to HyperOS only (not seeing "non-multi_" ROMs for MIUI. But my Mi11pro isn't on the list, so it looks like I won't get the EU module fix through the updater app any more. Seems like I will have to keep watching this thread with the manual updates. Got it to work for the last days, stopped working again today, holding up the queue in the store :D
Short question, my old Mi 9 (cepheus) is on latest MIUI 12.6 weekly and also not enabling payment.
Is there any fix for this (old) device available?
Did anyone manage to get Hub working? (com.airwatch.androidagen)?

It's part of a suite from my work.

VMware Workspace One intelligent Hub.

My phone is all meeting the Play device integrity and MagiskHide enable for that app.. But it always keeps detecting Root and refuses to install :(

(on Mi10, stable HyperOS)