Resolved Launcher bug


MMETMA66

Members
Mar 20, 2020
108
40
Swiping down from the left side or the right side of the home screen both show the notifications shade
I'm using lavender latest beta 20.12.28

In previous version it showed the control center when swiping from the right and the notifications shade when swiping from the left//cloud.tapatalk.com/s/5fef00707d02b/Screenrecorder.mp4

Sent from my Redmi Note 7 using Tapatalk
 
  • Like
Reactions: nikai90

nikai90

Members
May 4, 2020
51
20
Sam here, control center on right side only possible when swiping from outside inside the screen.
 

MMETMA66

Members
Mar 20, 2020
108
40
Like aadil said
Sent from my Redmi Note 7 using Tapatalk
 
Last edited:

aadil.gillani

Members
Nov 26, 2020
116
40
Do you understand Java's order of execution of class static initialization blocks?...
Actually My Friend Sipollo is a Modder who mods the latest launcher to enable Google Feed and all layouts so he invested a large amount of time in order to fix this specific issue but sadly he couldn't but he was very curious to find how the issue was fixed

During his time looking through the classes.dex he finded that the issue occurs only when gfeed option is present but still he couldn't find what was causing the issue.

If it is possible could you share how the issue was fixed if it's ok for you.

Thanks in Advance Igor Eisberg

Sent from my Redmi K20 using Tapatalk
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
7,172
322
Actually My Friend Sipollo is a Modder who mods the latest launcher to enable Google Feed and all layouts so he invested a large amount of time in order to fix this specific issue but sadly he couldn't but he was very curious to find how the issue was fixed

During his time looking through the classes.dex he finded that the issue occurs only when gfeed option is present but still he couldn't find what was causing the issue.

If it is possible could you share how the issue was fixed if it's ok for you.

Thanks in Advance Igor Eisberg

Sent from my Redmi K20 using Tapatalk
As a general rule, we don't share our wisdom, we're not exactly an open-source project.
I'll throw you a hint: the issue seems to be caused by DeviceConfig class being initialized before Utilities class, but DeviceConfig depends on certain values set in Utilities class, which were not yet initialized, so DeviceConfig gets incorrect values and the whole launcher starts to behave unexpectedly.