New MI2S cannot connect to wifi WPA/WPA2

Discussion in 'Bugs' started by damienrayne, Aug 11, 2014.

  1. damienrayne

    Mar 23, 2012
    33
    1
    18
    Male
    self employee
    penang, malaysia
    hi all,

    i have problems connecting to wifi with wpa/wpa2 security even though i have the password. it keeps obtaining for ip address. im running on dual boots.
    in both rom i cannot connect to the wifi. i have tried single boot with both systems and no problem connecting to the wifi with wpa/wpa2 security. the only problem is when i change to dual boot

    device : xiaomi mi2s
    system 1 : cyanogenmod 11-20140725-NIGHTLY-aries
    system 2 : WIUI-4.7.18
    android ver : 4.4.4 kitkat (both system)

    are there any flash zip to fix this?

    thanks
     
  2. damienrayne

    Mar 23, 2012
    33
    1
    18
    Male
    self employee
    penang, malaysia
    additional info..
    no problem connecting to wifi with wep security type
     
  3. qbert456

    qbert456Members

    Feb 20, 2013
    517
    36
    65
    I've always had WiFi problems with my mi2,I never really proper fixed it (still using mi2 now).
    I am not entirely sure, it's not the router to blame despite no other phone having any problems...
     
  4. damienrayne

    Mar 23, 2012
    33
    1
    18
    Male
    self employee
    penang, malaysia
    qbert456, what rom do you use? is it official or fan build? i dont think there would be problem with official build. and what mi2 do you use? mi2s or mi2a?
     
  5. qbert456

    qbert456Members

    Feb 20, 2013
    517
    36
    65
    I have mi2 using 4.81.1 jb wiui
    My other half used to use a mi2s weekly rom from this site and she had the problem quite bad. We both use WiFi fixer app which may have improved things.
    I read somewhere tho that the router may need tweaking, I did and it certainly helped.
    I'll look for the article today.


    She has an iPhone now (sorry! ) and has no problems with WiFi.
     

Share Our Site