New [mi5] Autostart & Apps Battery Usage


ironwick

Members
May 27, 2016
27
15
Hello all,
I've found (at least on Mi5, 7.3.17 and later, now on 7.4.14 too) and some other forum members in spanish "htcmania" forum that the Autostart permissions and the option "Manage apps battery usage" is just not working at all. I mean, I have tried to put the Power saving mode in "On" and even in "Ultimate" and try to choose some apps like whatsapp and others to limit the background activity.
What's the problem? Every time someone writes me I keep receiving notifications. And the same behaviour happens with any other application. Furthermore, when I enter the Installed apps and I look which apps are running and/or in cache, all the applications I don't want to be in background, are running!!

As I say, this was not a problem until the 7.3.17 or 24 (I can't remember). I tried to jump back to 7.2.24 and everything was OK, if I didn't give autostart permission to an app and give it the proper battery usage, it did not open in background until I manually open it. That was really great, but now it just doesn't work, even the ultimate mode let every apps to open itself.
 

pajaro

Members
Oct 23, 2014
1
23
To me also happens to me, and it is very annoying, I hope they solve it soon.

Enviado desde mi MI 5 mediante Tapatalk
 
  • Like
Reactions: ironwick

ironwick

Members
May 27, 2016
27
15
Still the same s**t in 7.4.20 on Mi5. Whatsapp: no autostart permission, blocked background activity and keep notifying whenever it wants... I'm going to Global. This is VERY ANNOYING.
 
  • Like
Reactions: Stefano131270

ironwick

Members
May 27, 2016
27
15
Has anyone found a solution for the problem?
No it's still broken. Even more, now Google Maps and many other apps open themselves. So as I said autostart permission and battery management is definitely useless right now. They should remove as now I need to root the device and install greenify... Then I lose the ability to pay via NFC.

I'm really disapointed with this.
 

ironwick

Members
May 27, 2016
27
15
disable miui optimization on developer mode
and upgrade to 7.4.27 it work to for late notificaton
I'm trying this.
With MIUI optimization enabled in the 7.4.27 is not working, I've just disabled.

OK, right now I've received a message from an app that I have set to not start automatically and in the battery management as block every background activity. So for me disabling MIUI is not working.
 

ironwick

Members
May 27, 2016
27
15
7.5.4 still the same fu**ing problem. I'm starting to think that maybe it's time to move to OnePlus 5 if it deserves the effort.