patchrom help

Discussion in 'Porting Advice/Help' started by 1982Strand, Apr 23, 2012.

  1. iBotPeaches

    iBotPeaches Script Gatekeeper Staff Member

    Trophy Points:
    People started taking my work and releasing it at XDA as there own. I'm no longer pushing updates to that apktool until its finished. Only a couple of MA Staff have access the updated 1.4.6 build. Sorry :(
  2. 1982Strand

    1982Strand Members

    Trophy Points:
    Ok, i understand :) People are d*cks!
    Looking forward to see it finished!
    Btw, any ideas about the error i get? Thanks for all your help..
  3. iBotPeaches

    iBotPeaches Script Gatekeeper Staff Member

    Trophy Points:
    Post the contents of YOUR ROM folder/metadata/recovery.fstab for me.

    I think that might be it.
  4. 1982Strand

    1982Strand Members

    Trophy Points:
    Here you go:

    # mount point    fstype        device            [device2]
    /boot        mtd        boot
    /cache        yaffs2        cache
    /data        yaffs2        userdata
    /misc        mtd        misc
    /recovery    mtd        recovery
    /sdcard        vfat        /dev/block/mmcblk0p1    /dev/block/mmcblk0
    /system        yaffs2        system
    /sd-ext        ext3        /dev/block/mmcblk0p2
    EDIT: SOLVED. By simply copying the metadata folder from the "honor" directory into my devices folder.. But i wonder if there are any "sideeffects" from this?
  5. ingbrzy

    ingbrzy Multilang leader Staff Member

    Trophy Points:
    Hello.. I have problem with make fullota with patchrom...

    it has this error..

    ingbrzy@ingbrzy-ubuntu:~/patchrom/i9100$ make fullota
    >>> Install framework resources for apktool...
    install framework-miui-res.apk
    /home/ingbrzy/patchrom/tools/apktool --quiet if /home/ingbrzy/patchrom/miui/system/framework/framework-miui-res.apk
    unzip >/dev/null "system/framework/*.apk" -d out
    install out/system/framework/twframework-res.apk
    install out/system/framework/framework-res.apk
    <<< install framework resources completed!
    >>> build out/framework-res.apk...
    add miui overlay resources
    /home/ingbrzy/patchrom/tools/ >/dev/null out/framework-res
    /home/ingbrzy/patchrom/tools/apktool --quiet b out/framework-res out/framework-res.apk
    Exception in thread "main" brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [aapt, p, -F, /tmp/APKTOOL1678287356629398603.tmp, -x, -S, /home/ingbrzy/patchrom/i9100/out/framework-res/res, -M, /home/ingbrzy/patchrom/i9100/out/framework-res/AndroidManifest.xml]
    at brut.androlib.res.AndrolibResources.aaptPackage(
    at brut.androlib.Androlib.buildResourcesFull(
    at brut.androlib.Androlib.buildResources(
    at brut.apktool.Main.cmdBuild(
    at brut.apktool.Main.main(
    Caused by: brut.common.BrutException: could not exec command: [aapt, p, -F, /tmp/APKTOOL1678287356629398603.tmp, -x, -S, /home/ingbrzy/patchrom/i9100/out/framework-res/res, -M, /home/ingbrzy/patchrom/i9100/out/framework-res/AndroidManifest.xml]
    at brut.util.OS.exec(
    at brut.androlib.res.AndrolibResources.aaptPackage(
    ... 6 more
    Caused by: Cannot run program "aapt": error=13, Permission denied
    at java.lang.ProcessBuilder.start(
    at java.lang.Runtime.exec(
    at java.lang.Runtime.exec(
    at brut.util.OS.exec(
    ... 7 more
    Caused by: error=13, Permission denied
    at java.lang.UNIXProcess.<init>(
    at java.lang.ProcessImpl.start(
    at java.lang.ProcessBuilder.start(
    ... 10 more
    make: *** [out/framework-res.apk] Error 1

    Do you know help me..?

    trying building SGS2 build... thx...


  6. 1982Strand

    1982Strand Members

    Trophy Points:
    Not sure if anyone is still reading here, but today i ran into a new problem. It's a new one, as i've been able to use patchrom successfully for a while now, until today.
    Did a repo sync and noticed there were changes to and, it seems the framework miui-res changes id from 3 to 6 and some dummy apks from 2-5 are installed.

    This is what i get, during make workspace:

    if unzip >/dev/null system/framework/framework-res.apk -d out >/dev/null; then /root/patchrom/tools/apktool --quiet d -f out/system/framework/framework-res.apk framework-res ; else echo system/framework/framework-res.apk does not exist, ignored!; fi

    Where is my base rom
    The event is defined around line 198 in, but i'm unsure if it's something i can fix and how..? Anyone got ideas?

Share Our Site