Phone and Contacts not opening up

Discussion in 'Xiaomi Mi 3' started by Ramgopal, Jul 10, 2014.

  1. Ramgopal

    RamgopalMembers

    Mar 27, 2014
    25
    0
    11
    Male
    Friends - After upgrading to the latest ROM (WCDMA), all the Xiaomi app like Phone, Contacts and Messenger app dont open up. It briefly opens only to close immediately.

    Kindly help how can I fix this.
     
  2. marcio_bianco

    Jul 1, 2013
    22
    6
    15
    Male
    Flash again? Wipe data/cache ?
     
  3. Ex:Jhon Doe

    Jul 10, 2014
    153
    17
    28
    Just clean the user data (all cache) and you should be fine.
     
  4. Ramgopal

    RamgopalMembers

    Mar 27, 2014
    25
    0
    11
    Male
    Thanks. but can you pls guide how do I do that? I checked in Settings but couldn't find. Please help.
     
  5. Ramgopal

    RamgopalMembers

    Mar 27, 2014
    25
    0
    11
    Male
    I think I figured it.. Went to Settings, Apps, chose 'Phone Dialer' and 'Contacts' and cleared the data and cache. Hope this is right..

    But even after this, the Phone and Contacts don't open up..
     
  6. Ramgopal

    RamgopalMembers

    Mar 27, 2014
    25
    0
    11
    Male
    Ok. Here is what I have found..

    If I flash the 'Stable ROM', the Phone, Contacts, Messenger won't work.
    If I flash the 'Developer ROM', some of the 'System' apps are missing and Google Play won't work. Phone/Contacts are ok.

    I also tried to flash Singapore WCDMA flash, as I read in one of the forum that all apps will work, but I couldn't even flash it. Gave an error when I tried to upgrade. Not sure why.

    Given these details, can some Guru help me please to fix this.. just need all essential apps to work.

    Thanks a lot.
     
  7. Ex:Jhon Doe

    Jul 10, 2014
    153
    17
    28
    Clean reinstall?
     
  8. Ramgopal

    RamgopalMembers

    Mar 27, 2014
    25
    0
    11
    Male
    Yes. Clean every time except the Singapore version which didn't allow to start. Rest were fine
     
  9. Ex:Jhon Doe

    Jul 10, 2014
    153
    17
    28
    #9Ex:Jhon Doe,Jul 12, 2014
    Last edited: Jul 12, 2014
    And after you flashed ROM did you restore your data from back up? If yes, the problem can be in some corruption file which is there.

    I would suggest to back up your data and to do the clean reinstall with multi 4.7.11. Test if the problem persists and only after that restore your data from back up.
     
  10. Ramgopal

    RamgopalMembers

    Mar 27, 2014
    25
    0
    11
    Male
    Hi, thanks for the comments. No I did not restore from backup before. But after your advice, did it but no help. The apps wouldn't open still.

    I will try to reinstall. But pls suggest where can I download multi 4.7.11?
     
  11. Ramgopal

    RamgopalMembers

    Mar 27, 2014
    25
    0
    11
    Male
    I found this under the ROM section. For Xiaomi Mi3 WCDMA, should I download the 'Cancro' file or something else? please suggest.
     

Share Our Site