Redmi Note 3 Pro Won't Chrage


May 27, 2016
23
10
15
#1
At the end of the day plugged in my RN3P into Aukey Quick Charge 2 power supply and Anker sleeved USB cable at about 15% battery level. Phone got very hot in next few minutes and just stopped charging.

Now phone works normally, is cold and has about 8% of charge. I tried different sockets, different cables (tried original as well). I only have one charger with 5V/2A output.

WHAT DO I DO?

**EDIT:** I think the issue is the Anker cable i bought from ********** and used about 2-3 times prior to the accident.

When i connect the phone to PC with original USB cable i got THIS error message.

Users had similar issues:
I have the exact same situation as you had. My two days old Redmi Note 3 SD suddenly stopped charging on QC 2.0 charger at 20% and then started giving short circuit on every the USB port after disconnect from this charger.

Just as you, I have tried many cables and chargers without success. Then after your suggestion I connected to USB 3.0 port on my old PC and it started working!!! It works now with alle the chargers again.
Unfortunately when i connect the phone to USB 3.0 or 2.0 ports on my laptop on AC it gives me error i just posted above.

I found possible solution on MIUI forums:
After connecting a faulty USB cable my phone stopped connecting to PC and charging - It shows the symptoms of being in USB Host mode permanently.

I was able to charge the phone by entering engineering mode (Dial *#*#3646633#*#* ) and going to the Hardware Testing tab, scrolling up to UART/USB switch and selecting UART

The phone would then charge normally.
The problem is, i can't enter engineering mode as i use CM13. I can't flash native MIUI ROM via EDL as the phone is not recognized by PC.

The only possible solution i found so far is:
I had that problem too. And I did what u did too.. the problem is that there is some sort of confusion between Otg and USB... so you will have to short circuit the charging port to revive it.
First open up your phone. To make the internal components visible.
Then connect ur charger to the phone.
While the charger is connected, use a flat metal or wire to short circuit the charging port. You should see a small spark and your phone would off.
Connect battery and Switch it back on. If it doesn't work try again for three -four times. If it doesn't still work then send your phone for repairs.
Don't be afraid, it's only 5volts your phone won't blow up. Short circuiting the charging port would revive it..
I did that to mine and it has been working well till now.
I'm not sure if that's a good idea but i don't know what else to do.
ANY HELP IS APPRECIATED!
 
Last edited:
Jun 28, 2017
1
0
1
#2
Hi,

I have the same problem: my phone didn't charged. I downgraded from 8.2 to 8.1 and it works. 3 weeks later, without any upgrade/update happened again: you connected the cable usb to the phone and it didin't charged.

I sent it to manteinance and they downgrade again. What happend? What is the problem. I don't trust in the phone because it can avoid of charge any moment.

Any Idea?

Here you have my post 2 months ago...
en.miui.com/thread-581746-1-1.html

Now i works, but .... when it will fail again????? Which morning i'll get up with my mobile phone at 17% after charge whole night?