New Redmi Note 9 Pro miui 11 no caller ID when receiving


Denovo

Members
Oct 27, 2020
4
13
I am in the Netherlands and on a dutch carrier Vodafone. When people call me I don’t see their caller ID. Tested it with 2 other networks and on both I can see who is calling me.

What strange is that when I switch to 3G network it works but on 4G network I can’t see caller ID when receiving calls.

I tried deleting caches but I don’t wanna do to much to it because it is still within the warranty period. I just don’t wanna send it in and be left without my phone for weeks.


Sent from my iPhone using Tapatalk
 

dio_yahoo

Members
Oct 13, 2020
13
15
I'm having the same problem. I don't have this issue with my 2nd SIM by Ben.How do you switch to 3G? Vodafone doesn't offer 3G anymore.
 
Last edited:

Pipinello

Members
Sep 28, 2020
2
13
I am having the same problem with my Mi 10 Note with Vodafone Germany and I am close to throw this unusable phone out of the window. Even with Xiaomi.eu-ROMS the bug did not vanish
 

Denovo

Members
Oct 27, 2020
4
13
I am in the Netherlands and on a dutch carrier Vodafone. When people call me I don’t see their caller ID. Tested it with 2 other networks and on both I can see who is calling me.

What strange is that when I switch to 3G network it works but on 4G network I can’t see caller ID when receiving calls.

I tried deleting caches but I don’t wanna do to much to it because it is still within the warranty period. I just don’t wanna send it in and be left without my phone for weeks.


Sent from my iPhone using Tapatalk

And now I can’t send sms anymore


Sent from my iPhone using Tapatalk
 

dio_yahoo

Members
Oct 13, 2020
13
15
My problem is solved. I'm using a so called duo SIM and fiddled around with both SIMs; first deactivated the SIM in one phone, then took the SIM out from the Redmi, then taking the one out from the other phone, then took them both out of my phones and put it back in and in the end, the caller ID was showing again.

So my conclusion is that in my case the problem was due to a flaw in registering one of my SIMs to the network.

I must add, that recently I updated my "contacts & dialer" app; first installing GetApps, then setting my location to India and then let the app update itself in GetApps.
 
Last edited: