Update To Lollipop


Apr 28, 2015
278
114
67
#1
I'm on 6.3.3 with the TWRP it came with (3.0.0-0);
Trying to update to the new lollipop rom with updater app, but after it reboots to TWRP it says:
Update for "wt86947", this is ""

How did you guys owners of 2014813 managed to proceed?

Enviado do meu Redmi 2 (2014813)
 
Apr 28, 2015
278
114
67
#2
Nevermind, I managed to do it:
First, I reinstalled TWRP with updater app (the same package I had installed, before updating to rom 6.3.3);
The package is the same that came with the rom 6.3.3, so it's 3.0.0-0.

After, I repeated the new rom installation (also starting from updater app).
I don't know why, but this time it proceeded normally and installed it correctly.

The only thing I had changed in TWRP was the timezone... so I don't know why it was failing, since it's the same version.
 
Jan 20, 2016
20
2
13
#3
Hi, tonirai!
I see you didn't made any wipes of data, before or after the transition...
And yet you succeeded..
Anyway, what timezone did you put in TWARP? The real one according to your region?
 
Apr 28, 2015
278
114
67
#4
Vass66, I answer to you here instead of in the weekly rom thread.

When the change to TWRP came, I didn't do the first update (was waiting for OTA, which didn't come), so later I updated to 6.3.3.

To do that, I had to first install TWRP, which I did downloading the version from the first post, and installing from updater app. Then, I did the same with the 6.3.3 file. All went well.
I skipped the next updates.

Now, I was trying to do exactly the same with the rom file 6.3.25, but the process was aborted at start... I tried twice.

I then tried to reinstall TWRP (the same file which was already in my download folder), and repeated the process with the rom, and all went well.

The TWRP was the same, so my only guess is that this reinstallation overwrited the previous and its settings... And the only non default setting that I had changed was the time zone - I changed it from default (I think it was gmt-5) to my own (gmt).
So it returned back to default.

About wipes, this time I didn't do any, and all went well.
On the previous installation (6.3.3), inside TWRP, I had done a full backup, then wiped cache and dalvik, then rebooted and update from updater app.

This time I only did a full backup, no wipes.

About the battery it's too soon to tell, but it seems normal or better.
But the antutu score was frankly better than the last one I did long ago... I remember it was around 21000, but now is above 26000. Same antutu version.

Are you having problems updating, or just asking before trying?
Hope I helped you.

Enviado do meu Redmi 2 (2014813)
 
Last edited:
Likes: Vass66
Jan 20, 2016
20
2
13
#5
Thank you, tonirai!
I fully understand what you did - your explanations are excellent!
I am still on 6.2.24 KK and I like the behaviour of this ROM.
I've read about some "Error 7" in TWARP when trying to install the 6.2.25 Lollipop ROM...
Then some said we have to make some "full wipes" (before or after installing - no one said)...
So I got suspicious about if, how and when to try installing the new Lollipop update.
Now I see that you've been lucky, after all.. No wipes necessary, all went well..and so on.
Thank you, once again!
 
Dec 12, 2015
25
10
15
#6
Hello, i own a 2014813 and i was on 6.3.24, tried to update to lollipop 6.3.25. Installation in TWRP (3.0.0-0) went ok but the phone stays at mi logo and nothing more. Waited for more than 30 min but nothing! Tried to reinstall TWRP and flash the rom again but same result, did all wipes.. don't know what to do...
Thank you for any information you can give me.
Cheers.
 
Last edited:
Apr 28, 2015
278
114
67
#7
Hello, i own a 2014813 and i was on 6.3.24, tried to update to lollipop 6.3.25. Installation in TWRP (3.0.0-0) went ok but the phone stays at mi logo and nothing more. Waited for more than 30 min but nothing! Tried to reinstall TWRP and flash the rom again but same result, did all wipes.. don't know what to do...
Thank you for any information you can give me.
Cheers.
You could try with the TWRP suggested at post #646 of this week's thread.
Let us know if it works.

Enviado do meu Redmi 2 (2014813)
 
Likes: vite74
Dec 12, 2015
25
10
15
#8
You could try with the TWRP suggested at post #646 of this week's thread.
Let us know if it works.

Enviado do meu Redmi 2 (2014813)
Thank you!
Already tried that recovery version and also an older one, no way, same result. Don't know, i own this device since a year and i never had problems with EU updates.
Another update is coming, let's see if I will more lucky...
Thank you again.
Cheers.
 
Last edited:
Apr 3, 2016
8
0
13
#14
Hi, I am new in the forum and have redmi 2 pro (2.014.813) with xiaomi.eu 6.3.24 developer (4.4). For the update to 6.3.31 (5.1) I have to make flash from TWRP of xiaomi.eu_multi_wt86047_6.3.31_v7-5.1.zip?
 
Last edited:
Apr 28, 2015
278
114
67
#15
Hi, I am new in the forum and have redmi 2 pro (2.014.813) with xiaomi.eu 6.3.24 developer (4.4). For the update to 6.3.31 (5.1) I have to make flash from TWRP of xiaomi.eu_multi_wt86047_6.3.31_v7-5.1.zip?
Yes. Or directly from updater (with TWRP already installed, first).

Enviado do meu Redmi 2 (2014813)
 
Apr 28, 2015
278
114
67
#16
Some of the pros/cons I've found so far of this upgrade to 5.1:

Pros:
Everything works fine, all menus, etc;
My translation (pt-pt) has no leftovers;
Battery consumption seems improved.

Cons:
5.1 additional security limits Tasker and secure settings habilities to do stuff, like turning data on/off and keyguard on/off. This really bugs me as it messes with my profiles and they can't do certain things anymore;
Embedded smartlock feature lacks wifi and location (only has Bluetooth), and Bluetooth doesn't even detects my Bluetooth devices... So it's basically worthless.

Enviado do meu Redmi 2 (2014813)
 
Apr 28, 2015
278
114
67
#18
Hi, i can't get root access in all the apps. Only recognize Root Explorer...
In Settings, Installed apps, it closes when y try to scroll
Normally, you have to first use the app and make it ask root (or give error) ;
Then, you go to security app, permissions, root, and grant permission there.

Enviado do meu Redmi 2 (2014813)
 
Apr 28, 2015
278
114
67
#19
I have the scroll bug too.
Some have reported closing immediately when trying to enter installed apps.
I'm sure it will be later corrected.

Enviado do meu Redmi 2 (2014813)
 
Apr 28, 2015
278
114
67
#21
thanks, but i can't... the app not appears at "Permissions", only appears Root explorer... It's like Root uninstaller don't ask for root acces
Have you tried using the app first and make it complain it hasn't root, and only THEN go to security app?
If so, I don't know.

Enviado do meu Redmi 2 (2014813)
 
Apr 28, 2015
278
114
67
#22
Is it just me that when you I leave airplane mode, it doesn't ask me for the pin? The option is on, of course.

Enviado do meu Redmi 2 (2014813)
 
Jan 3, 2016
4
0
11
#23
Hi
I have 2014813 variant with kk 5.10.22 Europe dev ROM . I am preparing to install lollipop update but I don't know how to do it. Is there any instructions?
Is lollipop better than kk ?
Does it worth to try to install it?
Thanks for response.

Sent from my 2014813 using Tapatalk
 
Jun 18, 2014
130
27
50
#24
I was using miui global dev rom, updated from kk rom, at fist I gave me some problems on my redmi 2 enhanced.
I used miui system backup for all my data, fuuly wiped my phone and used mi recovery to update to cn dev rom(5.1.1) used flashify to flash this twrp.img: http://en.miui.com/forum.php?mod=viewthread&tid=249552&extra=page=1&mobile=2, choosed a correct version of your model. With twrp 3.0.0-1 to flash a miui global dev rom(lollipop) + flashed superSU 2.65.zip for rooting. Then I restored back my data and it works great for me. Mi drop, mi mover, gps, bluetool, all works. Not facing any fc problem. Battery good as well.

Sent from my Redmi Note 2 using Tapatalk
 
Last edited:
Apr 28, 2015
278
114
67
#25
About what I was saying of improved battery SOT:





This is 100% with indoor use, so the screen is always darker... But I've done this before and it barely had passed 5h of SOT.

One other bug I seem to have is in the hardware section of battery use, it only shows me 3 items... As you can see, I used wifi, but it's not listed.

Enviado do meu 2014813 através de Tapatalk