Voice Search / browser problem

Discussion in 'Bugs' started by cyberstoic, Aug 15, 2011.

  1. cyberstoic

    cyberstoicMembers

    Apr 20, 2011
    209
    1
    40
    Psychologist
    The Windy City
    Voice search appears to work, but when the browser launches it goes to the start page of the browser and the info does not load into it. I saw a post about loading a previous browser and loaded from 1.6.24 to 1.7.22 with no luck, it will not work and just FC's. Thought it should be reported.
     
  2. easyrider

    easyriderMembers

    Mar 29, 2011
    21
    0
    11
    I have the same problem. The voice search only opens the browser, but does not bring up any searches based on the search term spoken.
     
  3. cyberstoic

    cyberstoicMembers

    Apr 20, 2011
    209
    1
    40
    Psychologist
    The Windy City
    Well spoken, that is exactly what it is doing.

    And like I said, I pulled the browser.apk from previous builds that had the old browser, removed the new one and installed this and no go, it FC's. I read a post that said it had to be named Browser2.apk instead of browser, and that also FC's. Even tried pulling the browser from cm latest nightly and also no go. In any case, the problem seems to be a google voice search integration problem.
     
  4. cyberspaced

    Nov 6, 2010
    66
    3
    18
    It kinda works, just click the back arrow and then the forward arrow in the browser! ;o)
     
  5. Dead-I

    Dead-IMembers

    Nov 21, 2010
    77
    1
    18
  6. cyberstoic

    cyberstoicMembers

    Apr 20, 2011
    209
    1
    40
    Psychologist
    The Windy City
    Perhaps give me an assist in what you did. I have removed the old browser, pushed the new (old) browser - browser2.apk - into the system/app directory, set permissions to rw-r--r-- , which was how the permissions were set on the current browser and installed it. I get nothing but force closes. I tried the browser2.apk that you had, as well as previous browsers from builds 1.6.24 up to 1.7.22 . I tried the browser from CM7 rc1 as well. All I get is force closes when I launch the browser. Oh well, perhaps the voice search will be better integrated on the next build. Although it is not the voice search in the browser that is the issue for me, it is in navigation that is the issue.
     
  7. Dead-I

    Dead-IMembers

    Nov 21, 2010
    77
    1
    18
    I did exactly what you did, but after setting permissions all I did was reboot the phone, I didn't click on the app to install it.
     
  8. cyberstoic

    cyberstoicMembers

    Apr 20, 2011
    209
    1
    40
    Psychologist
    The Windy City
    Thanks! I will try that!


    Update:
    --Deleted current Browser.apk from /system/app
    --Downloaded the Browser2.apk you gave, thank you much!
    --I used Root Explorer (because I am at work with no computer with adb) and moved the Browser file into the /system/app file
    --set permissions as rw-r--r--
    --rebooted

    SUCCESS!
    Thanks much, I was installing the browser2.apk before and that is why it was not working.
     

Share Our Site