New Volume/Sound not playing over bluetooth device


Eidenz

Members
Dec 18, 2020
37
20
Alright so I've had this issue since the last 2 Xiaomi.eu weekly updates, and it's still there on the latest 21.4.21:

When I connect a bluetooth speaker/headset/etc.., the sound is still being output from the phone's speaker.
I tried unpairing the device, using different sound/volume presets, using different apps, restarting the phone multiple times, enabling/disabling battery saver.. And doing all of this again after a new weekly update came out.

To keep it weird, the bluetooth device is correctly paired since I can control the sound volume using it, pause music/videos, anything a normal bluetooth speaker/headset can do when it's connected you know.
I might add that, quite rarely, it fixes itself and the sound will go back to output to the bluetooth device for some reason. And more often, it starts on bluetooth for like 5sec before reverting to phone's speaker (even though Android tells me it is currently outputing from bluetooth). Forcing bluetooth instead of "default" does not change anything.

And yes, I tried it with 3 different bluetooth devices which used to work flawlessly before the last two weekly updates (when we were still on 12.5 instead of 12.6 at least).


I'm using the Chinese Mi 11 with the latest 21.4.21 Xiaomi.eu weekly ROM.

Thanks for your help.
 

Alvy200

Members
Jan 30, 2021
287
52
Alright so I've had this issue since the last 2 Xiaomi.eu weekly updates, and it's still there on the latest 21.4.21:

When I connect a bluetooth speaker/headset/etc.., the sound is still being output from the phone's speaker.
I tried unpairing the device, using different sound/volume presets, using different apps, restarting the phone multiple times, enabling/disabling battery saver.. And doing all of this again after a new weekly update came out.

To keep it weird, the bluetooth device is correctly paired since I can control the sound volume using it, pause music/videos, anything a normal bluetooth speaker/headset can do when it's connected you know.
I might add that, quite rarely, it fixes itself and the sound will go back to output to the bluetooth device for some reason. And more often, it starts on bluetooth for like 5sec before reverting to phone's speaker (even though Android tells me it is currently outputing from bluetooth). Forcing bluetooth instead of "default" does not change anything.

And yes, I tried it with 3 different bluetooth devices which used to work flawlessly before the last two weekly updates (when we were still on 12.5 instead of 12.6 at least).


I'm using the Chinese Mi 11 with the latest 21.4.21 Xiaomi.eu weekly ROM.

Thanks for your help.
Just click the small icon on the bottom right corner of media notification and voilà

Sent from my M2007J3SG using Tapatalk
 

Alvy200

Members
Jan 30, 2021
287
52
Go into the Bluetooth devices properties, is USE FOR MEDIA AUDIO enabled?
When you connect with music off, and then play it, does it behave the same as connecting while playing?
Also try to reset network settings

And wiping dalvik /cache
d4e01d4f623a6530327e00a1087c2f04.jpg


Sent from my M2007J3SG using Tapatalk
 

Eidenz

Members
Dec 18, 2020
37
20
Go into the Bluetooth devices properties, is USE FOR MEDIA AUDIO enabled?
When you connect with music off, and then play it, does it behave the same as connecting while playing?
Also try to reset network settings

And wiping dalvik /cache

Sent from my M2007J3SG using Tapatalk

I forgot to mention it but yes, I went into the properties for each device I tried, media audio was enabled. Tried playing with the switch while music was playing, changing it then restarting the phone, etc.. Still the same problem.

And weirdly enough, when I do change the state of the "media audio" switch, it marks a quick pause just as it would normally do when changing these settings. But it keeps using the phone's speaker anyway.


Since I'm using a Mi 11, I can't wipe any kind of partition/cache (no TWRP yet). And I really don't want to go over the pain of factory reseting my phone.
 

Alvy200

Members
Jan 30, 2021
287
52
I forgot to mention it but yes, I went into the properties for each device I tried, media audio was enabled. Tried playing with the switch while music was playing, changing it then restarting the phone, etc.. Still the same problem.

And weirdly enough, when I do change the state of the "media audio" switch, it marks a quick pause just as it would normally do when changing these settings. But it keeps using the phone's speaker anyway.


Since I'm using a Mi 11, I can't wipe any kind of partition/cache (no TWRP yet). And I really don't want to go over the pain of factory reseting my phone.
Ok, got it

Sent from my M2007J3SG using Tapatalk
 

Eidenz

Members
Dec 18, 2020
37
20
Might have spoken a bit too soon, because it's back at doing it.

And this time, resetting won't fix it.
I really don't understand this bug as it seems completely random, I haven't touch any settings since that day though.
 

Eidenz

Members
Dec 18, 2020
37
20
Update:
I didn't do a lot of testing as I don't own a lot of bluetooth devices, but so far it seems to only affect some TWS earphones (ex: my Redmi Airdots 2). Bluetooth works just fine on my car's speakers.
 
Last edited: