New VoWIFI


Xiaomee

Members
Jun 5, 2021
14
5
I ran into the problem with VoWIFI.

VoWIFI turned on in SIM settings but nothing indicates that it actually works. I have VoLTE icon in Status Bar but no VoWIFI.
Also, when the phone is in airplane mode and wifi is already on a pop up said " turn off airplane mode or turn on wifi"...which is already on.
Any suggestions would be greatly appreciated to make VoWIFI work.
A part of my house has no coverage (phone service) but the wifi is perfectly working.
 
  • Like
Reactions: NiceOne123

osnix

Members
May 14, 2021
354
87
I ran into the problem with VoWIFI.

VoWIFI turned on in SIM settings but nothing indicates that it actually works. I have VoLTE icon in Status Bar but no VoWIFI.
Also, when the phone is in airplane mode and wifi is already on a pop up said " turn off airplane mode or turn on wifi"...which is already on.
Any suggestions would be greatly appreciated to make VoWIFI work.
A part of my house has no coverage (phone service) but the wifi is perfectly working.

Guys, please post your phone model and the ROM used at least.
 

Xiaomee

Members
Jun 5, 2021
14
5
Sorry, you absolutely right.
Xiaomi Mi10T Pro with 21.6.9 weekly (latest as of yesterday).
 

osnix

Members
May 14, 2021
354
87
Sorry, you absolutely right.
Xiaomi Mi10T Pro with 21.6.9 weekly (latest as of yesterday).

VoLTE & VoWIFI is working fine on Mi 11 on 21.6.9.

But let's try to find out :)

First, enable the VoLTE toggle if you didn't already:

Open the phone app and type:

*#*#86583#*#*

Now goto, Sim Setting, and disable, VoLTE & VoWIFI.
Wait a minute, and enable just VoWIFI, sometimes that VoLTE icon is just buggy
and won't change to VoWIFI, even VoWIFI is working.
 

Xiaomee

Members
Jun 5, 2021
14
5
VoLTE & VoWIFI is working fine on Mi 11 on 21.6.9.

But let's try to find out :)

First, enable the VoLTE toggle if you didn't already:

Open the phone app and type:

*#*#86583#*#*

Now goto, Sim Setting, and disable, VoLTE & VoWIFI.
Wait a minute, and enable just VoWIFI, sometimes that VoLTE icon is just buggy
and won't change to VoWIFI, even VoWIFI is working.

Funny thing...I do not have VoLTE toggle in the menu (I looked and even searched for it) just VoWIFI. In spite that I have VoLTE icon in the Status bar.
The closest I have is a toggle "Use mobile data during VoLTE calls on the secondary SIM" which is "off". because SIM2 doesn't have data.

Thanks for your help...I'll follow your instructions (obviously without the VoLTE toggle) and report back soon.
 

Xiaomee

Members
Jun 5, 2021
14
5
Funny thing...I do not have VoLTE toggle in the menu (I looked and even searched for it) just VoWIFI. In spite that I have VoLTE icon in the Status bar.
The closest I have is a toggle "Use mobile data during VoLTE calls on the secondary SIM" which is "off". because SIM2 doesn't have data.

Thanks for your help...I'll follow your instructions (obviously without the VoLTE toggle) and report back soon.

UPDATE:
Now I have VoLTE toggle:)

I followed the instructions but no luck.

I have VoLTE icon in Status Bar even when both(VoLTE, VoWIFI) are turned off.

I turned on VoWIFI only but no change.(VoLTE stay present)

I rebooted the phone...no change.

Any other suggestions also would be appreciated.
 

Xiaomee

Members
Jun 5, 2021
14
5
UPDATE:
Now I have VoLTE toggle:)

I followed the instructions but no luck.

I have VoLTE icon in Status Bar even when both(VoLTE, VoWIFI) are turned off.

I turned on VoWIFI only but no change.(VoLTE stay present)

I rebooted the phone...no change.

Any other suggestions also would be appreciated.

UPDATE 2:

I am sorry for the repeated entries but I found some changes after reboot.

-VoLTE toggle appeared in SIM2 options. There was no toggle before there and SIM2 only has voice service (no data) plan from the provider.
The "permanent" VoLTE icon now can be switched on/off by SIM2 toggle. ( I find it funny because that SIM has no data service)
-SIM2 has no VoWIFI toggle!

-SIM1 has both VoLTE and VoWIFI toggle but witching them has zero visible consequences. (Neither icons shows up in the Status Bar)

That's all. I hope you find it helpful.
 

osnix

Members
May 14, 2021
354
87
UPDATE:
Now I have VoLTE toggle:)

I followed the instructions but no luck.

I have VoLTE icon in Status Bar even when both(VoLTE, VoWIFI) are turned off.

I turned on VoWIFI only but no change.(VoLTE stay present)

I rebooted the phone...no change.

Any other suggestions also would be appreciated.

Strange...

Let me remember how you can monitor this ...

I believe that way:

Settings > About Phone -> All specs.Type on the Internal Storage until a new testing menu popping up.
On that menu type on Phone information1 ( which should be your SIM1 ).

Now you can see what is registered for your SIM and can play around, enabling/disabling WIFI, enabling/disabling
mobile data, turn off/on mobile radio power.

maybe it's just the icon who is stuck.. However for that I don't know what to do, and since I don't own any hardware with this bug, I'm not sure myself how to test here ;).
 

osnix

Members
May 14, 2021
354
87
UPDATE 2:

I am sorry for the repeated entries but I found some changes after reboot.

-VoLTE toggle appeared in SIM2 options. There was no toggle before there and SIM2 only has voice service (no data) plan from the provider.
The "permanent" VoLTE icon now can be switched on/off by SIM2 toggle. ( I find it funny because that SIM has no data service)
-SIM2 has no VoWIFI toggle!

-SIM1 has both VoLTE and VoWIFI toggle but witching them has zero visible consequences. (Neither icons shows up in the Status Bar)

That's all. I hope you find it helpful.

Yeah, it is a bit of fu** up. As an example on EEA ROM, the VoTLE icon is never there but VoLTE calls are working.

Having these options now is normal, but we need someone with the same phone to confirm that problem.
 

osnix

Members
May 14, 2021
354
87
@xcsvxangelx , I'm sorry to tag you, I just saw you have the same phone model from the
weekly rooms thread. If you have time could you confirm this bug? Or see if is working for you?
 

Xiaomee

Members
Jun 5, 2021
14
5
Strange...

Let me remember how you can monitor this ...

I believe that way:

Settings > About Phone -> All specs.Type on the Internal Storage until a new testing menu popping up.
On that menu type on Phone information1 ( which should be your SIM1 ).

Now you can see what is registered for your SIM and can play around, enabling/disabling WIFI, enabling/disabling
mobile data, turn off/on mobile radio power.

maybe it's just the icon who is stuck.. However for that I don't know what to do, and since I don't own any hardware with this bug, I'm not sure myself how to test here ;).

I looked at your suggestion and was able to find the appropriate "switches"... unfortunately they're all "greyed out"...see attached picture
 

Attachments

  • IMG_20210618_160636_1.jpg
    IMG_20210618_160636_1.jpg
    55.8 KB · Views: 232

Xiaomee

Members
Jun 5, 2021
14
5
@xcsvxangelx , I'm sorry to tag you, I just saw you have the same phone model from the
weekly rooms thread. If you have time could you confirm this bug? Or see if is working for you?

@osnix...I would like to thank you for the extra effort!... appreciated.

@xcsvxangelx ...thanks in advance.
The reason why I am so hanged on the VoWIFI because that's the only option for me in a certain part of my house.
 

osnix

Members
May 14, 2021
354
87
I looked at your suggestion and was able to find the appropriate "switches"... unfortunately they're all "greyed out"...see attached picture

Yes they are always greyed out :)

Let's find out if your mobile provider is provisioning the features...

Have both VoLTE & VoWIFI turned ON..

Turn off WIFI, open the menu and switch off Mobile radio power, wait some seconds then turn on and do nothing for a while.
Let it try to register/provision itself. See if that changes something, some features should jump to on.
 

Xiaomee

Members
Jun 5, 2021
14
5
Yes they are always greyed out :)

Let's find out if your mobile provider is provisioning the features...

Have both VoLTE & VoWIFI turned ON..

Turn off WIFI, open the menu and switch off Mobile radio power, wait some seconds then turn on and do nothing for a while.
Let it try to register/provision itself. See if that changes something, some features should jump to on.

No luck... nothing is jumping:-(

I'll try to talk to (confirm) with the providers...at least check their end.

I'll wait a couple of days to see that the new weekly ROM is okay before I put it on.
Maybe that will has some affect on it.

But if any solution/idea emerges in the meantime I'll try it in a heartbeat.
 

kozer

Members
Oct 6, 2021
2
3
In order to not open a new thread, and as I tried everything this thread suggests, I want to express my problem.
I have both wifi and volte enabled in the "secret menu" and in sim settings. (although in the menu are grayed out and cannot turn off)
I have poco f3 with the latest stable.
The strange thing is vowifi was working fine in original from the phone came up with (global 12.5.3)
I live in Greece if this helps, and I have Cosmote gr (WhatsUp) and Vodafone gr (cu).

I have disabled checks for both volte and vowifi (using *#*# codes)
Can anyone help more with this?
 

gogocar62

Members
Apr 22, 2021
1,305
297
In order to not open a new thread, and as I tried everything this thread suggests, I want to express my problem.
I have both wifi and volte enabled in the "secret menu" and in sim settings. (although in the menu are grayed out and cannot turn off)
I have poco f3 with the latest stable.
The strange thing is vowifi was working fine in original from the phone came up with (global 12.5.3)
I live in Greece if this helps, and I have Cosmote gr (WhatsUp) and Vodafone gr (cu).

I have disabled checks for both volte and vowifi (using *#*# codes)
Can anyone help more with this?