WiFi connected but no internet - Mi 11 Pro


Xtreme089

Members
Apr 8, 2021
14
15
Hi all,

I have the Mi 11 Pro with the stable EU ROM 12.5.4
At the beginning everything was great but in the recent weeks I have been experiencing very poor WiFi. It says it's connected and I have full signal but websites or apps won't load or very slowly.
Is this a bug or a hardware issue?

P.S. other people in my household don't have the issue so the WiFi is working just not for me.

Thanks
 
  • Like
Reactions: Portamento

Jimnasium

Members
May 16, 2021
389
67
I would suggest rebooting your router. The Mi 11 Pro sees your router and is connecting to it. The only reason I can think of off hand is there is a transmission problem bewteen the router and the device. If is still does not conect after rebooting router and device, try reinstalling the software on your phone and finally contacting your ISP.
 

Deflaktor

Members
Oct 19, 2021
2
3
Im having the same issue. Wlan full signal but can't visit websites or watch YouTube. Other mobiles phones are still working at the same time.
After 5-10 minutes the issue disappears again. But it is happening frequently and is quite annoying.
 
  • Like
Reactions: Portamento

Jimnasium

Members
May 16, 2021
389
67
Are you using 2.4 or 5 GHz. 2.4 is greatly affected by other devices in your home, as well as other betworks in your area. WiFi networks in your area may be accessing the same channel as you have are selected and the number of devices and what they are doing eat up bandwidth and of course that greatly affects the amount of bandwidth your ISP is allowing you to use.
 

Deflaktor

Members
Oct 19, 2021
2
3
I have dual channel wifi with both 2.4 ghz and 5 ghz.
Never had this issue with other devices in my network.
I will continue to monitor this issue and report if I find any pattern.
 
  • Like
Reactions: Portamento

Jimnasium

Members
May 16, 2021
389
67
I have dual channel wifi with both 2.4 ghz and 5 ghz.
Never had this issue with other devices in my network.
I will continue to monitor this issue and report if I find any pattern.
It isn't always the types of devices that is the problem, but rather the amount of devices and how much bandwidth is actually being used by those devices. How much bandwidth is your provider giving you? How many devices are online at any one time? What are those devices being used for, Gaming, Surfing websites, Videos, movies, work from home or school? Anything that requires video content will require more bandwidth. Try rebooting your router, Verify that neighbors wifi is not on the same channel as you and change your channel if there is a conflict. Also reset your modem/connection to your ISP I have the Mi 11 Ultra, which utilizes much of the same hardware as the Pro, and I am not having any problems what so ever. What are your download and upload speeds? Use Ookla speedtest app to verify this. Usually my DL 150-170 Mbps and UL of about 10-11 Mbps and unless my son is online gaming, which causes some buffering to my TV streaming, I have no issues.
 
Last edited: