Xiaomi Mijia Robot Vacuum-Mop Essential G1


felixpradoh

Members
Nov 26, 2022
1
3
Hello, I have a Xiaomi Mijia G1 vacuum mop (Chinese version). I do not have any problem with my iOS app, I can pair the robot to the 2.4GHz WiFi network (I had to choose the China Mainland).

Since I moved from home I have started having some troubles:

Once it starts cleaning, after some minutes it losses the connection, disconnects from the network, and just stops and turns off, once this happens I need to pick it up and put it back in the base station to reconnect it again. Sometimes it cleans for 10 mins, some others for 3 mins. It has never happened before when I was living in another place, it started to happen once I moved to my new place. I have connected the robot to a 2.4GHz PLC or a wifi repeater since the house has 3 floors and the robot is on the 3rd floor. I have tried with several PLCs and a wifi repeater and always happens the same. Does anyone know how to solve this problem? Should I get rid of this piece of trash? Why does it happen just once I moved?

I have also tried this: changed the router's 2.4GHz band to a free channel and consequently to my WiFi Repeater linked to the main router. I have charged the robot to its full capacity during the night. This morning I linked it again without problems. Once I started the cleaning I have done at the same time a ping from my PC to the robot and the wifi repeater. The device was working well, until (of course), it suddenly stopped. Instantaneously, I checked the ping and I got the “request timed out” error from the Robot but not from the wifi repeater. After this error, I only got a “destination host unreachable” error (obviously because the robot is OFF) and from the Xioami Home App, it says low battery, (cannot be because was running for 3 min at the lowest power) once I plug it into the station. So two things: (1) If I do not plug it into the charging station it says is disconnected. (2) If I plug it into the charging station it is connected without linking it and says low battery and charging. That makes me think that it has to be somehow an update error from a certain version onwards... I am going to try to move the robot to the ground floor and connect it to the main router without any repeater and check what happens...

Any ideas?