New 2.3.30 No Slide Lock / Default Lockscreen

Discussion in 'Bugs' started by fatjoez, Apr 2, 2012.

  1. fatjoez

    fatjoezMembers

    Aug 8, 2011
    35
    0
    16
    Since 2.3.23 it seems there is no more default lock screen - slide unlock
    Same for 2.3.30

    In security settings, can only turn screen lock on with Pattern,Pin,Password.

    How do you get just slide lock?

    phone: i9000 galaxy s
     
  2. kaefert

    kaefertMembers

    Mar 18, 2012
    19
    0
    11
    Male
    By just sliding the ON/OFF switch in the top right corner of the settings page [settings -> Security & privacy -> Screen lock] to OFF
    At least it works that way on the Huawei Honor 2.3.30 (always state your phone when reporting bugs!)
     
  3. fatjoez

    fatjoezMembers

    Aug 8, 2011
    35
    0
    16
    Hi Kaefert

    I tried this, slide on/off to OFF but when i press power button, screen turns off, but doesn't lock.

    using phone i9000 galaxy s
     
  4. Pele

    PeleGuest

    Try the following :
    • download a fresh copy of 2.3.30 i9000 update and place on sd card
    • reboot into cwm
    • wipe cache partition
    • clear dalvik
    • flash 2.3.30 i9000 update
    • reboot phone
    regards
     
  5. fatjoez

    fatjoezMembers

    Aug 8, 2011
    35
    0
    16
    Hi Pele

    Thanks I will try this, but just to clarify

    - I am running a Nexus S port of Miui v4 2.3.30
    - There used to be an option which said "slide lock" in security for screen lock, now there is only Pin,Password,Pattern
    - Someone else also had this problem on official MIUI Android 2.3.23 for SGS2,
    see here: http://miuiandroid.com/community/threads/miui-rom-2-3-23-roms-ics-gb.15847/page-17#post-114897

    So can you confirm whether the "slide unlock" option is still available as a selectable option,
    or as kaefert said is it just the default option when screen lock is off

    PS: this is what i mean by slide lock
    [​IMG]


    For Reference, quote from cplm
    Just realized that I have no screen lock on SGS2.
    Settings -> Security -> Screen lock is set to "None". If I try to change it I have only these options: Pattern, PIN and Password.. Selecting one of these options will activate the lock but I don't want to use any security features on it. I remember it worked on 2.3.16.
    I also checked on Google Nexus 2.3.24 and Screen lock is set to "Slide"
     
  6. Andy Thomson

    Andy ThomsonStaff Developer

    May 10, 2011
    1,316
    616
    230
    Senior Software Engineer
    Edinburgh, United Kingdom, United Kingdom
    I'm using a I9000 running MIUIv4 and mine works as above, I just slide the ON/OFF switch in the top right corner of the settings page [settings -> Security & privacy -> Screen lock] to OFF.
     
  7. fatjoez

    fatjoezMembers

    Aug 8, 2011
    35
    0
    16
    which brand of miuiv4 are you using? galnet? weui? speedrom?
    i just did a fresh install of MIUI v4 using speedrom 4.79 ill see if that fixes it
     
  8. Andy Thomson

    Andy ThomsonStaff Developer

    May 10, 2011
    1,316
    616
    230
    Senior Software Engineer
    Edinburgh, United Kingdom, United Kingdom
  9. fatjoez

    fatjoezMembers

    Aug 8, 2011
    35
    0
    16
    oh yep.
    well ive run WeUI & now im running "speed" with factory reset wipe data etc.
    lockscreen works now. decent stable.

    Some guy andy thomson huh haha.

    seems yours, speed & weui are all based off nexus s (rightly so),
    so is there any benefit in switching from a working speed rom to your version or would they be pretty similar
     

Share Our Site