MIUI 14 23.10.8


Status
Not open for further replies.
Ok, so on Diting right now, 2 minutes in, and the device shutdown. Like, not a reboot. It shut down.
Charger is plugged in, I was using the phone, then it blacked out. I tried turning on through the power button, but nothing happened. I suppose it was a reboot so I waited.
The Mi logo came on, then the green battery icon for charging. This means the phone has shut off.
Why? How can I get logs from that?

This is really new for me now. The phone shut down. It's not hot, it's not slow, it's not buggy... It literally just turned off suddenly on me. No warning or anything. I can't extract logs from a turned off phone. I can probably enter TWRP and extract logs from somewhere after the fact, but I need to know where.

I have turned the phone back on and I'm back to using it normally to see what happens.
-------
Again, less than 1 minute. Phone has stopped charging, I noticed it through the Ambient display that it wasn't charging, though connected. I pressed the power button to turn it on, the Ambient display faded away like if it was going to turn on, then it played the "charger disconnected" sound, then turned off again.

I have ACC through Magisk. I will try disabling it as fast as I can, as this might be interfering something.

--------

ACC off, still with shutdown issues. Also no sound. Charging keeps coming and going, and I think the reboot is triggered when an audio is played (such as playing music). I'll try to reproduce it a couple more times to confirm Can't confirm, I managed to "play" music in the background. Audio didn't come out, but the player was playing in the background. I installed a log app to recover logs, and as I opened it, the audio started working again, and it's charging consistently now. Could've been "fixed" by installing an app, or something worked out after a couple of minutes since boot.

I'll try rebooting the phone and seeing if the issue persists after a reboot, and see how to recover a whole log since boot.

---------

I haven't rebooted. I suppose the logs of it having issues, then sorting out somehow are also valuable.
These are the logs.

---------

If I keep music playing on the background (I left a music player playing music in the background, after audio went through), the phone doesn't bug out (audio works, charging works, doesn't shut down). The moment I stop the music, the charging bugs out after a little while, and audio is gone again. If I press play on the media player, it shows music as progressing, but no audio for 2-3 minutes. After I wait with the music progressing in the background, it suddenly comes back again, and phones resumes charging.

I'll clear logs, start recording, pause music, then resume music and wait until it starts playing again to stop the logs.

---------

Log recorded. It's almost 200K lines. That's how it went:

1 - Phone was charging, had music playing on the background
2 - Logs cleared. Started logging.
3 - Exactly at 00:50, music was paused. I could see a LOT of logs coming in.
4 - After 2-3 minutes, phone was still charging, though logging a LOT of stuff.
5 - Tried playing music again. No dice, audio wasn't coming through (Music player was working)
6 - After a while, charging stopped. Logging got even more intense
7 - A minute or two later, music comes through, phone starts charging, logging calms down significantly.
8 - When logging became relatively calm (not 10K lines/second), stopped recording the log and saved it.

Please analyze the issue. Maybe the device is "sleeping" too deeply, and by playing a music in the background prevents it?
If the logs aren't good enough, please tell me what I need to do.

---------

Roughly the same thing as above, but with less lines as I skipped a lot of waiting. Not sure if the log results are the same.
Here's the log and a video of how it's happening/how it was captured

and Here's just the log file
What I can see from your logs is an app called "Gravity Screen - On/Off" crashing the system...
 
What I can see from your logs is an app called "Gravity Screen - On/Off" crashing the system...
I have (what seems to be) the same issues as him and I don't have that app installed, as far as I know.

The app can't be the sole reason why it's crashing...
Could you have a look at the logs I posted on my previous post? Maybe they'll help checking what we both have in common.

Thanks in advance for your hard work!

First time I've had any "serious" issues with xiaomi.eu and I've been a user since 2019. Can't complain.
 
Last edited:
Are you going to release an update for DITTING or is it not going to come out until next week? It's just to know if you install all the apps and reconfigure the phone or the update, I will be able to put it on without doing anything strange, I can now enter TWRP without a problem
 
  • Like
Reactions: Waker
I do not know why the Screenshots are not shown in the screenshot/screenrecording album since a view updates ago and why they will not be synced with cloud ( mi12pro ) .
The positiv since this rom , notifications icons seems are not mor delayed on AOD.
 

Attachments

  • Screenshot_2023-10-14-16-14-30-839_com.miui.gallery.jpg
    Screenshot_2023-10-14-16-14-30-839_com.miui.gallery.jpg
    142.8 KB · Views: 128
Xiaomi 12 doesn't have this problem..
 

Attachments

  • Screenshot_2023-10-14-16-21-54-114_com.miui.gallery-edit.png
    Screenshot_2023-10-14-16-21-54-114_com.miui.gallery-edit.png
    600.1 KB · Views: 166
What I can see from your logs is an app called "Gravity Screen - On/Off" crashing the system...
I've uninstalled it, rebooted the system and we'll see how it goes.

I also do have Magisk.

--------------

Gravity Screen removed. Still no audio, doesn't charge etc.
Log spam before music starts playing, and the phone charges normally and plays audio as long as a music is playing.

Here's the logs since rebooting.


--------------

OK, caught in 4K.

I rebooted the phone, then immediately started logging through ADB right after unlocking the phone. I didn't start playing music, in order to capture the issue until shutdown. I used it for a short while (in the meantime, it was plugged in to the PC, but not charging), then let it idle. It was sitting idle, connected but not charging, until it suddenly shot to 0% battery and the Security app icon for low battery came up. It shot back to 90somethings, which was the actual charge, it played the charging animation, sound and all, but the animation froze mid animation.
Phone shut down after a couple of seconds, and the logging stopped automatically on the PC.

This time around, the phone didn't actually shut down like before. Before, it would literally turn off and the Mi logo would come up after a moment (because it was connected to a charger, and it 'booted up' to display the green battery icon). This time, the phone screen went black, as if it turned off like before, but nothing came on. I had to hold the power button for a long time, like forcing a restart. I suppose the phone got stuck in a black screen, however logging stopped like if the phone was disconnected/turned off.

Here's the log
 
Last edited:
  • Like
Reactions: Waker
I've uninstalled it, rebooted the system and we'll see how it goes.

I also do have Magisk.

--------------

Gravity Screen removed. Still no audio, doesn't charge etc.
Log spam before music starts playing, and the phone charges normally and plays audio as long as a music is playing.

Here's the logs since rebooting.


--------------

OK, caught in 4K.

I rebooted the phone, then immediately started logging through ADB right after unlocking the phone. I didn't start playing music, in order to capture the issue until shutdown. I used it for a short while (in the meantime, it was plugged in to the PC, but not charging), then let it idle. It was sitting idle, connected but not charging, until it suddenly shot to 0% battery and the Security app icon for low battery came up. It shot back to 90somethings, which was the actual charge, it played the charging animation, sound and all, but the animation froze mid animation.
Phone shut down after a couple of seconds, and the logging stopped automatically on the PC.

This time around, the phone didn't actually shut down like before. Before, it would literally turn off and the Mi logo would come up after a moment (because it was connected to a charger, and it 'booted up' to display the green battery icon). This time, the phone screen went black, as if it turned off like before, but nothing came on. I had to hold the power button for a long time, like forcing a restart. I suppose the phone got stuck in a black screen, however logging stopped like if the phone was disconnected/turned off.

Here's the log
Try to disable Google Voice Match in the Google app and reboot your device, let me know if it helps.
 
  • Like
Reactions: angriest and Waker
nuwa, fuxi, ishtar, mondrian, socrates are suspended due to Android 14 testing..
Good evening dear developer!
Sales of the new Xiaomi 13T and Xiaomi 13T Pro smartphones started a few weeks ago; they received the code names "aristotle" and "corot", respectively.
Please add these models to xiaomi.EU firmware
I gave a gift to a girl, she previously used your firmware on note 9 pro and wants to be with us again!
 
Try to disable Google Voice Match in the Google app and reboot your device, let me know if it helps.
You mean here?

Screenshot_2023-10-14-13-54-18-521_com.google.android.googlequicksearchbox.jpg

Ok, disabled. Rebooting.


-----------------

Seems to have done the trick. Audio is OK, charging isn't going back and forth, and device hasn't shutdown so far. It's working like if a music were playing before.
But that's a workaround for the time being, right? I use the hey google a lot.
 
Last edited by a moderator:
Good evening dear developer!
Sales of the new Xiaomi 13T and Xiaomi 13T Pro smartphones started a few weeks ago; they received the code names "aristotle" and "corot", respectively.
Please add these models to xiaomi.EU firmware
I gave a gift to a girl, she previously used your firmware on note 9 pro and wants to be with us again!
So you shouldn't have bought a device with a MediaTek SoC. :p These devices are not supported here.

Support for the Mi 13T Pro is on Patreon.
 
I am also having problems with the ditting model. I downgraded to the previous version and now on top of that I can't decrypt the twrp, the unlock password doesn't work. Solution?? Now on top It does not turn on since it is stuck at the beginning of the factory reset....
I tried doing the same thing. Now TWRP does not accept my password. The best I could do was get the phone to work and log into the system, but in any application I try to open, it says that I need to wait for the system to completely restart. Now it's screwed, I'm going to have to format it and lose everything
 
I tried doing the same thing. Now TWRP does not accept my password. The best I could do was get the phone to work and log into the system, but in any application I try to open, it says that I need to wait for the system to completely restart. Now it's screwed, I'm going to have to format it and lose everything
Then install the latest fastboot version, that is, the one that is going wrong, just update so as not to lose anything. It has errors from reboots etc but twrp now works and turns on the phone
 
Try to disable Google Voice Match in the Google app and reboot your device, let me know if it helps.
Fixed it for me as well.
I do also use Google assistant so it'd be nice to have that back when possible :)

Thanks for diving through the logs and figuring it out!
 
  • Like
Reactions: angriest
I see that Diting was taken down. The ROM is working normally with Hey Google turned off, which I can only suppose it's something to do with the audio set struggling with the always listening feature or something.

Thankfully, with Hey Google turned off, I can patiently wait for the next release/fix, albeit with the nuisance of having to manually trigger the Google Assistant for the time being.

Thanks for the speedy identification and workaround, devs.
 
I see that Diting was taken down. The ROM is working normally with Hey Google turned off, which I can only suppose it's something to do with the audio set struggling with the always listening feature or something.

Thankfully, with Hey Google turned off, I can patiently wait for the next release/fix, albeit with the nuisance of having to manually trigger the Google Assistant for the time being.

Thanks for the speedy identification and workaround, devs.
Although i have xm12pro , thanks both users and devs for this partnership (if this is the right word) , to find a solution... loved the forum for this.
 
  • Like
Reactions: Waker
But stable Chinese Android 14 builds are available since 2023-09-21 ? Why Not Test with this Version ?
Because recompiling certain apps is impossible right now due to Google changes.

I see that Diting was taken down. The ROM is working normally with Hey Google turned off, which I can only suppose it's something to do with the audio set struggling with the always listening feature or something.
I assume that they updated the firmware so the Voice Match modules we use are no longer compatible. We'll see if we can find any compatible ones...
 
Status
Not open for further replies.

Similar threads