Activation of VoLTE and VoWIFI in xiaomi.eu ROM


gogocar62

Members
Apr 22, 2021
1,087
297
1. Enter the string * # * # 86583 # * # * in the field for dialing numbers, a message will appear after the last character, which must end with DISABLE. If ENABLE, we repeat the string again. This will allow VoLTE because this menu is hidden by default.
img_20200710_112231-jpg.39131

2. Enter the string * # * # 869434 # * # * as above, again the message with DISABLE must appear at the end. We have enabled VoWIFI.

3. Using the SIM card settings, we adjust the SIM card number in the international format, ie + 4xx .... I don't know if it's necessary, but some sources state it, so I listened and set it up. Activate VoLTE and VoWIFI
bez-n%C3%A1zvu-png.39129

3. enter the code in the stock MIUI Dialer app: * # * # 663368378 # * # *
then "MBN config loading and activing tool", then "Advanced" button. You should see that "oem_sw.txt" is selected for the auto-detection list - set it to "mbn_eea.txt" and then "Validate" and "ok".

Bez-n-zvu.png



4. Restart the phone and both functions should be active. We test VoWIFI by selecting the mode on the plane and then turning on WiFi and trying to call someone. If we succeed, we have won.
 
Last edited:

kisapl

Members
Jan 20, 2022
3
3
ok, I have MIUI Global 12.5.5.0 RKHMIXM Stabil and in this version isn't working.
In the last step of shortcut maker i clicked few times validate and update before vowifi icon appeared. Maybe try that
 

nicos

Members
Jan 19, 2022
4
3
In the last step of shortcut maker i clicked few times validate and update before vowifi icon appeared. Maybe try that
Shortcut Maker isn't working on my phone, if I going to Activity | Modem become following error:
Parts of operations are prohibited. Please apply to Modem staff for control right, see screenshot.
 

Attachments

  • Screenshot_2022-01-20-23-00-29-628_com.xiaomi.mtb.jpg
    Screenshot_2022-01-20-23-00-29-628_com.xiaomi.mtb.jpg
    112.5 KB · Views: 209

Igor Eisberg

Developer
Staff member
Oct 6, 2016
7,187
322
Shortcut Maker isn't working on my phone, if I going to Activity | Modem become following error:
Parts of operations are prohibited. Please apply to Modem staff for control right, see screenshot.
You can't access "MODEM test tools" (aka Rueban / MTB) app on official ROMs without authorized Mi Account...
 

zexl42

Members
Mar 10, 2021
2
13
i been using this method for 3 years , but now with the Rueban v2.4 keep crashing every time i access the modem config mode , any idea ?
 

tapirsu

Members
Mar 16, 2022
2
3
@gogocar62 , I have a problem while using the shortcut maker..after i clicked try this shortcut at modem, ..it stated this "parts of operations are prohibited. Please apply to modem staff for control rights"..how do I apply? thanks!
 

xeGox

Members
Feb 26, 2013
487
62
I can't set it to "mbn_eea.txt" and then "Validate" it, I don't have "mbn_eea.txt" option
 

Birraque

Members
Nov 12, 2018
57
20
"mba_eea.txt" only exists on Snapdragon 865 devices, as far as I know.

Hi @Igor Eisberg and @gogocar62

I running Beta Weekly on Poco F3 with Carrier (Vivo - Brazil - LATAM) that already support VoLTE and VoWiFi (both enabled my device Settings).

1) My default MBN settings before any change was:
mbn_01.jpg

2) Then I select mbn_global.txt from SW MBN list (validade), LATAM/Vivo/Commercial/BR/mcfg_sw.mbn (Act) and reboot my device.
mbn_02.jpg

But VoLTE and VoWiFi still doesn't work and MBN config loading and activing tool has the red NO DEFAULT MBN on top screen.
mbn_03.jpg

I double checked with my carrier and both services are provisioned in my number even doesn't work with Poco F3.
How can we handle it? Thanks in advance for your inputs.
Let me know if you need more information.

Regards,
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
7,187
322
Hi @Igor Eisberg and @gogocar62

I running Beta Weekly on Poco F3 with Carrier (Vivo - Brazil - LATAM) that already support VoLTE and VoWiFi (both enabled my device Settings).

1) My default MBN settings before any change was:
View attachment 42264

2) Then I select mbn_global.txt from SW MBN list (validade), LATAM/Vivo/Commercial/BR/mcfg_sw.mbn (Act) and reboot my device.
View attachment 42265

But VoLTE and VoWiFi still doesn't work and MBN config loading and activing tool has the red NO DEFAULT MBN on top screen.
View attachment 42266

I double checked with my carrier and both services are provisioned in my number even doesn't work with Poco F3.
How can we handle it? Thanks in advance for your inputs.
Let me know if you need more information.

Regards,
It's a "Commercial" MBN for Vivo BR, not a VoLTE-supported one most likely. If there isn't a VoLTE MBN for Vivo BR specifically, try a generic one.
The red "NO DEFAULT MBN" text on top screen is normal, it says that you manually selected a SW MBN, instead of letting it being set automatically.
 
  • Like
Reactions: Birraque