Android Auto on brand new Xiaomi Mi 9T (EU) isn't working.


Toukassay

Members
Jun 20, 2019
6
5
Hi,

I've bought a Xiaomi Mi 9T and got a Peugeot 208 (2018). When I plug my phone via the USB of my car, I got a really quick black flash on the phone's screen then the car's screen show something like "Please re-plug your phone or the is it's compatible".
I've try several cables, the one I've keep have been used over 1 year with my Oneplus 3 without any issue with Android Auto.

Can someone test it please ?
 

Cangrejo

Members
Jun 21, 2019
1
3
The same in a Ford tourneo courier. It does not work. I have tried with the original cable, I have reinstalled android auto and doesn't work... With my alt pocophone I have no problems...
 

Toukassay

Members
Jun 20, 2019
6
5
Almost happy to hear it :( At least it's not my specific car or phone configuration.
But very very disapointed.. I use AA everyday so I'll have no choice to send the phone back :/ Can't wait "i dunno how many time" for an update..
 

Lynskyn

Members
Jun 21, 2019
3
3
Exactly same problem with Citroen C3 combined with Xiaomi Mi 9T ( Previous phone was a Huawei G8 without issue ) . While i'm in car 2 hours everyday and using AA , I have to wait just a little time for xiaomi fixing the problem. It 's a pitty because Mi 9T is a very nice and powerfull phone ...
 

harrytheweb

Members
May 14, 2013
55
20
Same here, p30 pro works no issue. Mi9t not working. Says can not connect. Using 2018 VW golf

How do we report to Xiaomi?
 

takui

Members
Aug 28, 2013
109
30
Kinda weird, I've the k20 pro chinese version and it worked both with the chinese rom than with the .eu rom frankly...so it's tied to the cpu maybe? Idk but it's almost the only possible difference that would matter... (btw AA sometimes recognize music apps sometimes not and sometimse it started as was night even if wasn't, a little buggy bug usable)
 

La Bouclette

Members
May 3, 2019
5
3
update 10.3.10.0 received in France today and the problem remains the same. I sent a lot of emails and the answers are not adapted at all :(
 

takui

Members
Aug 28, 2013
109
30
Guys try the new global rom from india. Nfc doesn't work by default for now but Google works fine, even assistant. For me, auto worked with any roms i had, from china to xiaomi.it to xiaomi.eu and now global india. Maybe u have to update your android auto from the car side?
 

zac2b

Members
Jul 22, 2019
2
3
I also got update now I've got ROM Global 10.3.10, Google Play Services 18.3.81, AA 4.4592344.
AA opens but car do not detect it.
 

kebab

Members
Jul 22, 2019
2
3
I have the same issue with my phone Mi 9T. Plus, phone doesn't work at all with DJI drone controller. I have feeling that these problems have something in common. Meanwhile returning phone back. Unusable.
 
Last edited:

takui

Members
Aug 28, 2013
109
30
I also got update now I've got ROM Global 10.3.10, Google Play Services 18.3.81, AA 4.4592344.
AA opens but car do not detect it.
I meant to update your car infortainment system. For example, I've read that it didnt work well with the previous version of it for my car, but it works with the last version. I've a suzuki. U should research your model car on google and any info related to android auto, u could find hints that will lead u to update it to solve your issues, if you are lucky
 

Whatsek

Members
Jun 10, 2016
25
15
I fixed it by going into developer settings, 'Feature Flags' and turned settings_bluetooth_while_driving to 'on'
It was disabled. After that, AA worked.

K20 Pro, 9.7.19 EU rom.

Verstuurd vanaf mijn Redmi K20 Pro met Tapatalk
 

takui

Members
Aug 28, 2013
109
30
U was trying to use it only on Bluetooth? I don't... it's a drain and not so fluid...i use bt for calls only but for navigation and music (and recharge) i connect it anyway to a cable...
 

Whatsek

Members
Jun 10, 2016
25
15
U was trying to use it only on Bluetooth? I don't... it's a drain and not so fluid...i use bt for calls only but for navigation and music (and recharge) i connect it anyway to a cable...
No, I use an USB cable.

Verstuurd vanaf mijn Redmi K20 Pro met Tapatalk
 

La Bouclette

Members
May 3, 2019
5
3
I fixed it by going into developer settings, 'Feature Flags' and turned settings_bluetooth_while_driving to 'on'
It was disabled. After that, AA worked.

K20 Pro, 9.7.19 EU rom.

Verstuurd vanaf mijn Redmi K20 Pro met Tapatalk
I have an MI9T version 10.3.10.0 and this trick does not work, I always have the same error message
 

La Bouclette

Members
May 3, 2019
5
3
[QUOTE = "kebab, post: 496056, member: 243989"]
J'ai résolu ce problème en renvoyant le téléphone au magasin et en achetant un téléphone Samsung. : /
[/CITATION]ah ah ah !