[ASK]No sound on call

Discussion in 'Xiaomi Mi 2 / Mi 2S' started by nochtavio, Jun 17, 2013.

  1. nochtavio

    nochtavioMembers

    Oct 17, 2012
    144
    12
    28
    Male
    PHP Programmer
    Indonesia
    Hi everyone.

    Recently I've got a weird bug which I can't hear any sound at all on call. Somehow the bug fixed itself, but I got the bug again . . .

    I tried to restart but still . . .

    Thanks for help :)
     
  2. xepyonx

    xepyonxMembers

    Apr 8, 2013
    117
    36
    40
    Male
    I also experienced this once. The phone vibrated when the call connected and the call timer started, but no sound at all and the person on the other side couldn't hear me either. The problem was definately on my end, because I tried calling my voicemail and the same thing happened. After a reboot everything was working normal again and I haven't encountered this issue again since.
     
  3. nochtavio

    nochtavioMembers

    Oct 17, 2012
    144
    12
    28
    Male
    PHP Programmer
    Indonesia
    I tried reboot, reflash, but still can't hear any sound at all on call . . .

    Btw, I'm on the latest update, 3.6.14
     
  4. nochtavio

    nochtavioMembers

    Oct 17, 2012
    144
    12
    28
    Male
    PHP Programmer
    Indonesia
  5. ingbrzy

    ingbrzyXiaomi.eu Multilang leader
    Staff Member

    try any of stock chinese MIUI flash via MiFlash.. then another SIM card... when it all fails, its HW issue...
     
  6. rqdb

    rqdbMembers

    Jun 17, 2013
    19
    3
    13
    Hi guys,

    I got the same problem here, no sounds during call.
    If you switch between internal and external during silent call, speakers sounds get back.

    I tried different roms and radios but both didn't fix the problem.

    I try with a stock android and I keep you informed.

    Glad to not be alone :)
     
    nochtavio and xepyonx like this.
  7. nochtavio

    nochtavioMembers

    Oct 17, 2012
    144
    12
    28
    Male
    PHP Programmer
    Indonesia
    I'll also try with the stock one.
     
  8. rqdb

    rqdbMembers

    Jun 17, 2013
    19
    3
    13
    Hi,

    bug still present with QT14 stock but happenned just one time today.
    I'm gonna try with a different SIM tomorrow.

    I'm beginning to think that's an HW problem...
     
  9. nochtavio

    nochtavioMembers

    Oct 17, 2012
    144
    12
    28
    Male
    PHP Programmer
    Indonesia
    Well, the bug still present on me too on stock QDT10. I guess it's HW problem . . .

    Bad luck. I'll need to bring my headset everywhere then.
     
  10. rqdb

    rqdbMembers

    Jun 17, 2013
    19
    3
    13
    I tried with an other sim card today. Result is the same.

    I'm going to send it back to xiaomi for testing/reparing.

    Nothing else to do...
     
  11. xXxWOExXx

    xXxWOExXxMembers

    May 21, 2013
    8
    0
    21
    Male
    Korbach, Germany
    Isn't it a bug with the stock Android Roms?
    Try to go back on latest miui Rom and try to call again, maybe this will solve the problems

    Sent from my MI 2 using Tapatalk 2
     
  12. rqdb

    rqdbMembers

    Jun 17, 2013
    19
    3
    13
    Originaly the bug was under miui rom. I tried with a stock and now I'm back on miui but bug is still present.
    I also tried with a different sim card.

    It's probably an HW problem.
     
  13. rqdb

    rqdbMembers

    Jun 17, 2013
    19
    3
    13
    Hi guys,

    just to say that I'm back on v4 and bug seems to have disappeared.
    I keep you informed if it's back.
     
  14. HaQi

    HaQiMembers

    May 27, 2013
    25
    0
    11
    I have xioami S2 32GB for 4 months.
    I have this problem too. I can't hear people calling me, they CAN hear me.

    It appears few weeks ago. But the problem got solved 'automatically'.
    Now I have the same problem again. I don't hear the dail-tone, when calling. Really annoying!!!
    I'm on 4.1.1 JRO03L and MIUI-JLB20.0
    Now I'm using head-phone. to call and receive...
     
  15. rqdb

    rqdbMembers

    Jun 17, 2013
    19
    3
    13
    Go back to V4, it worked for me.
     
  16. HaQi

    HaQiMembers

    May 27, 2013
    25
    0
    11
    I rather go to 4.3, when it's available...
     
  17. rqdb

    rqdbMembers

    Jun 17, 2013
    19
    3
    13
    Hi guys,

    the problem is still present every week and I'm starting to be bored of it.
    Does someone has an idea to solve that problem ?
    Is it possible to adapt V4 kernel or other part of his code on V5 rom (sorry if I say stupidities) ?

    Thanks in advance.
     
  18. Redbean

    RedbeanMembers

    Jul 19, 2013
    120
    12
    28
    Male
    I have this bug since the first time I bought it.
    I have seen many threads about this issue but unfortunately no fix for this.
    Currently I m still surviving this bug. What I did was to open loud speaker whenever I received a call or making a call. Then off the speaker when you start talking.

    Hopefully it helps you guys somehow.

    ps: this problem had made me wonder with quite some people having this problem, if this is a bug from the rom, or is it because of a few batches of faulty phone produced by Xiaomi.
     
  19. rqdb

    rqdbMembers

    Jun 17, 2013
    19
    3
    13
    Hi Rebean,

    I guess this bug comes only from rom because it doesn't exit on V4 rom. Of course we could go back on V4, but if it's the only solution I prefer change my phone.
    Hope Xiaomi will invetigate on that problem.
     
  20. Benardo

    BenardoMembers

    Jun 17, 2014
    10
    2
    13
    Male

    Hi Redbean and HaQi,
    Have you finally solve this problem ?
    Im a new user of Xiaomi and found the similar problems.

    Thanks!
     
  21. touristtam

    touristtamMembers

    Jun 24, 2013
    1
    0
    11
    Male
    #22touristtam,Aug 20, 2014
    Last edited: Aug 20, 2014
    hi.

    I just started experiencing a similar issue: I can make and receive call, but only the speaker works. The other person will hear me regardless of whether I am using the loud speaker or the regular one, but I can not hear them through the regular speaker. No sound at all. I have been using this phone for over a year now:

    Model: Mi 2s
    MIUI: MIUI-4.8.15
    Android: 4.1.1JRO03L

    I have tried to launch the radio and the media player and closing them, and rebooting the device but still no sound.

    I have just done a factory reset and still the issue remains. :(

    right, I have uninstalled the MiKey as per this post's advise (http://en.miui.com/forum.php?mod=redirect&goto=findpost&ptid=20698&pid=550519) and now it is working? ! Oo. Weird.

    So for now it is working although, not knowing where the issue is coming from, I can not guaranty it will last or this is a universal fix. :/
     
  22. davfiala

    davfialaMembers

    Aug 20, 2013
    550
    199
    80
    Male
    Land Rover addict
    Czech Republic
    Most likely bad connection of earpiece speaker.
     

Share Our Site