Sound stops working during calls, requires restart - Xiaomi Redmi Note 12


Jan 16, 2024
SOLVED: Sent it into service and they had to replace the motherboard.

Hello. I bought my mom a Xiaomi Redmi Note 12, 8GB RAM, 256GB about a month ago and she has continuous problems with it during calls.

During the call, the sound completely stops working - she stops hearing the person she's in a call with, and that person doesn't hear her anymore. Even if she tries calling the person again, or if the person calls her, the problem still persists. The only way to solve the issue is to restart the phone. This happens randomly, a few times a week or even a few times a day.

Phone has all the latest updates, I have tried to reset to factory settings, and even disabled google assistant as I've read others having this problem that it was a solution for some of them. So far all I've done changed nothing, the problem persists.

Has anyone had this problem and successfuly solved it? My last resort would be to send the phone to the service for warranty, but the problem is this issue shows up randomly, and I'm worried they won't be able to reproduce it - since I doubt they will spend a few hours trying to make calls to see if the sound stops - and send me the phone back with no changes.

Last edited:
  • Like
Reactions: GiovanniG
Similar issue for me and my brother (I have the readmi note12 pro 5g and my brother has the 4g version). During a phone call, doesn't matter if it is a normal call or an internet call with WhatsApp or Facebook, the other side doesn't ear me. As far as I have seen, this happens mainly if the other side is speaking and I try to speak. Seems that only one at the same time can speak, not bidirectionally. I will try to do a restart and see if this will impact the quality of a call. I will check if this issue happens after the cache cleaning or other particular operation we could do on the phone. At a first impression, seems to be a bug from the software.
In my case it wasn't software. Sent it into service and they had to replace the motherboard.