Backup can't back most things up

Discussion in 'Question & Answers' started by Raphaël Briand, Mar 15, 2012.

  1. Raphaël Briand

    Mar 15, 2012
    25
    0
    11
    Male
    Not sure why it's not working, but when I tell Backup to backup only a few things work - most things, the important things like desktop layout, just say "task failed" with no further explanation, every time. The version of the app is 3.1 and I'm using a Samsung Galaxy SII I9100, android version 2.3.7 currently running MIUI 2.1.13. Check the photos.

    shot_000009.pngshot_000014.pngshot_000008.png
     
  2. iBotPeaches

    iBotPeachesScript Gatekeeper

    Oct 31, 2011
    3,811
    1,115
    335
    Kansas
  3. Raphaël Briand

    Mar 15, 2012
    25
    0
    11
    Male
    I tried the Backup apk that I extracted from the new version's zip, it did that same thing. I'm trying to back up in this way so that I can safely upgrade to the latest version, and I can't upgrade if I haven't backed everything up. All of this was so that I could upgrade to 2.3.9. As soon as I can backup my desktop layout I'll be on 2.3.9 like a shot. I really want to upgrade as soon as I can, but it would be too much to redo my desktops from scratch. Please help me back up. Excuse this post, I'm very, extremely drunk.
     
  4. iBotPeaches

    iBotPeachesScript Gatekeeper

    Oct 31, 2011
    3,811
    1,115
    335
    Kansas
    The backup app is hardly the entire app. MIUI needs "backup-able" code which is located in JARs and stuff everywhere.

    So moving one APK won't work. Do a NANDROID backup in recovery. Flash the new version and see if it worked. If not, restore back. If it did work, congrats. If you don't wipe cache on a MIUI -> MIUI upgrade your home screen placement should stay the same. If it doesn't though, thats why you took the backup :p
     
  5. Raphaël Briand

    Mar 15, 2012
    25
    0
    11
    Male
    Huh... now I have a weird and completely different problem - flashing the .zip of 2.3.9 does nothing. I followed your instructions to the letter and I've flashed things before of course, and it tell me that it has installed the .zip correctly, but I reboot and I'm still using 2.1.13. Any ideas?
     
  6. iBotPeaches

    iBotPeachesScript Gatekeeper

    Oct 31, 2011
    3,811
    1,115
    335
    Kansas
    That is very strange. Try wiping the cache prior to flashing. Then flashing 2.3.9 via clockworkmod. Look for any possible ABORT error, and then reboot from recovery.
     

Share Our Site