New known (or unknown) misc MIUI14 issues on "Star" ROMs


Jun 12, 2023
Dear DEVs, members,

I ve got a 11 Ultra (CN device), in which I ve been using some .EU roms for some time now and have few remarks
I have initially used the stable (V14.0.6.0.TKACNXM_v14-13) and currently a DEV build ( My observations apply to both builds, so please bear with me

1) Adhoc choppy video recordings
I heavily use the phone for photos but mostly video recording
My 'go to' setting for video recording is 4K60. Although I ve tried other 3rd party apps (e.g. OpenCamera), here my comments are about using the supplied build-in camera app
Sometimes, parts of the video are very choppy (frames missing for few seconds) and then back to normal framerate. I cannot establish whats causing this, as this device should easily handle the bandwidth I/O of 60fps
This occurs even on a fresh install, with no other apps or clutter that could possibly create a bottleneck. My 11 Ultra is the 12GB RAM version, so it doesn't make sense how such a high spec device can be chocked so easily and result in dropped frames/choppy recordings. Besides that, I keep the phone tidy and clean so it should perform at its best. Never faced this issue with other vendors (e.g. Samsung Galaxy S phones I had over the years..). Even my humble Pixel 3, never dropped any frames whilst recording
Like I said, this occur adhoc, so its not possible to reproduce on demand. Any hints what I could look? Any decent diagnostic app that can show me system resources in real time, so perhaps I can narrow it down a bit?

2) Deleted files whereabouts
I ve got 256GB of storage. Minus few GBs for OS/apps, that should still leave me with plenty of storage
Recently, whilst on holidays, I discovered yet another (design) fault the hard way
All over sudden, I got the error "insufficient disk space", after which I could not record videos (or even take photos) anymore
Tried troubleshooting this for hours, at the worse possible time, whilst on a tour, where I could not use the phone at all
Tried everything that was on YT - from deep scanning, clearing cache etc. No result. Even deleted some GBs of videos/photos which didn't change anything. Even though the actual size of my files was reported as 50something GBs, I could not establish where all my disk space had vanished. Looked every folder via the 'storage access framework'. Couldn't find a 'trash' or a 'bin', in order to check for possible 'deleted' files that occupied space. Couldn't find any (like in other Android versions where I had to empty the Bin)
Eventually, after bashing my head for hours, finally found the culprit: Settings >> MyDevice >> Storage
Then, selecting "apps and data" and scrolling all the way down, there's an option "shared files"
In there, to my horror, I found all previously deleted files including GBs of videos which where prefixed with a full stop "." + original filename. Those must have been marked as hidden (because they are not visible from anywhere else!) and were obviously not really purged (as what they should be, when you select something for deletion)
Only reason I was able to run into this problem was because I do a lot of video recording and therefore deleting those files, since they are not actually deleted and stay there forever, are bound to make the system run out of disk. Furthermore, ironically, the "Cleaner" app is totally useless, as it doesn't pickup those files, which would kind of alleviate the problem
This is a very serious design fault in my opinion. One which is not mentioned anywhere else (in any forum). So my guess is that when someone reaches that stage, they ll probably need to format/reset the device (which I find ridiculous). Or maybe blame the hardware (which is totally irrelevant)
Like I said - this is a (major) design fault of the original ROM (on which the .EU is based). So I don't expect you guys can do anything about it. I m only mentioning this so that people are aware

3) "nullnull"
I don't know exactly how to describe this, but sometimes, when I navigate to a file (or folder), it doesn't immediatelly show up the usual info (e.g. size, time stamp). Instead it just shows up as either "null" and "nullnull". But after few seconds or minutes, or by navigating to another location and coming back...the "nullnull" is now replaced by the size/date (what it should display in first place). I am not sure whats causing this behavior, but I find it a bit worrying as far as file integrity goes (at first, I thought those files are corrupted). Is later Android versions don't refresh file size/attributes in real time? Or is it relying on a background task and does that at another time when usage is lower perhaps (as to not inhibit performance)? Like for example when defrag/antivirus programs usually work in Windows (just an example!)

Anyhow, these are my impressions so far
I think that regardless what type of user you are, and however you utilize the phone, you are bound to run into some or all of those issues I described above
Does anyone have had any of those issues (surely, someone must have!)
Are those introduced in the latest MIUI or were known from previous releases?

I can see that V14.0.9.0.TKACNXM_v14-13 (stable) has been out for couple of weeks now
I wonder if I should give it a go and see if any of those issues have been mitigated (except for the 2nd issue of course, which to me is a clear design fault)

Just sharing my opinion guys. No pun intended
Any feedback is appreciated!


Jun 12, 2023
One more issue, but not sure if this is related to the OS somehow: incorrect file icons (in the build-in file explorer)

I have recently installed 'Audio Recorder' from the play store. After recording some audio files (in ".ogg" format), I realized that these files have been using one of my photos (already in storage) as their icon!

I looked everywhere for a 'defaults programms' or 'file association' menu where I could possibly change the default file icon for a given file extension. Is there even something like this in Android or it cannot be changed?