Camera2 API on Oreo (Miui10) is possible?


kapiyer

Members
Jun 17, 2018
2
13
camera2 api works on 10.0.5.0!!! yeeees! However i cannot find the suitable *no-support-for-this-app-on-this-forum* version that has front portrait working. any advice on what version to use? oh, and i also already flashed the GCam_FIXPORTRAIT_HDR_JASON.zip file but still no luck. thanks :D
 

angyone1

Members
Aug 7, 2018
94
20
camera2 api works on 10.0.5.0!!! yeeees! However i cannot find the suitable *no-support-for-this-app-on-this-forum* version that has front portrait working. any advice on what version to use? oh, and i also already flashed the GCam_FIXPORTRAIT_HDR_JASON.zip file but still no luck. thanks :D
With dxo trick?
 

leledumbo

Members
Jul 26, 2013
357
52
camera2 api works on 10.0.5.0!!! yeeees! However i cannot find the suitable *no-support-for-this-app-on-this-forum* version that has front portrait working. any advice on what version to use? oh, and i also already flashed the GCam_FIXPORTRAIT_HDR_JASON.zip file but still no luck. thanks :D
Use this magisk module instead (delete that .txt from the name), it's an amalgamation of many existing modules. At least what you want is covered and working.
 

Attachments

  • Like
Reactions: Depump

angyone1

Members
Aug 7, 2018
94
20
Use this magisk module instead (delete that .txt from the name), it's an amalgamation of many existing modules. At least what you want is covered and working.
sorry, just install this module or I need also the old GCam_FIXPORTRAIT_HDR_JASON.zip module?

THX !
 

Depump

Members
Oct 20, 2018
23
15
Use this magisk module instead (delete that .txt from the name), it's an amalgamation of many existing modules. At least what you want is covered and working.
Do you have Maximum profile ?

i see your file name is Jason.all.in.one_minimal. or have only minimal no maximum profile.
 

leledumbo

Members
Jul 26, 2013
357
52
sorry, just install this module or I need also the old GCam_FIXPORTRAIT_HDR_JASON.zip module?

THX !
Just this one, but having the other active is no harm, just useless as this one is already covered.
Do you have Maximum profile ?

i see your file name is Jason.all.in.one_minimal. or have only minimal no maximum profile.
No, I think minimal here refers to everything cramped into single file, no relation to performance or anything like that.
 

fabiomaga

Members
Aug 25, 2018
35
20
Hi, guys. Can you explain me whIch *no-support-for-this-app-on-this-forum* version do you use? I need Magisk and flash this last zip module posted by leledumbo? Is it enough to make it work? Thanks a lot!
 
Last edited:

CosminGFX

Members
Jul 18, 2018
13
15
Hi, guys. Can you explain me whIch *no-support-for-this-app-on-this-forum* version do you use? I need Magisk and flash this last zip module posted by leledumbo? Is it enough to make it work? Thanks a lot!
Not really, you'll also need to edit the build.prop to enable camera2api. The stock camera will no longer be able to use HDR, but *no-support-for-this-app-on-this-forum* is way, way better in every aspect. After that, just go to *no-support-for-this-app-on-this-forum* Ports website and test many APKs, see which one suits you better. Pixel2Mods are working flawlessly, while Pixel3Mods have some bugs, not everything is working and it's rather slow compared to Pixel2Mods. But it has Google Lens and Motion. Also, Arnovas are the best.
 
  • Like
Reactions: fabiomaga

Depump

Members
Oct 20, 2018
23
15
Must be something else, bluetooth works fine on me. A logcat might be helpful.
i wipe cache already everything is fine but i check with app name is Manual Camera test , it show disable every mode .

but if i add HAL3 in build.prop instead of use magisk , it's work.
 

leledumbo

Members
Jul 26, 2013
357
52
i wipe cache already everything is fine but i check with app name is Manual Camera test , it show disable every mode .

but if i add HAL3 in build.prop instead of use magisk , it's work.
Looks like the magisk module doesn't load somehow, this is what the module should write into build.prop:
Code:
persist.camera.eis.enable=1
persist.camera.HAL3.enabled=1
vendor.camera.aux.packagelist=com.google.android.GoogleCameraWide,com.google.android.GoogleCameraTele,com.android.camera
camera.hal1.packagelist=com.whatsapp
 

Depump

Members
Oct 20, 2018
23
15
Thank you for code

i see something after install module
it has #persist.camera.HAL3.enabled=1
but why has # in code
 

leledumbo

Members
Jul 26, 2013
357
52
Thank you for code

i see something after install module
it has #persist.camera.HAL3.enabled=1
but why has # in code
# means comment, the corresponding line then is not read by whoever should read build.prop. Do you use any other magisk module or any other hack (e.g.: init.d) that modifies build.prop? It's very easy for them to interfere each other.
 

jeamy

Members
Dec 18, 2013
36
20
# means comment, the corresponding line then is not read by whoever should read build.prop. Do you use any other magisk module or any other hack (e.g.: init.d) that modifies build.prop? It's very easy for them to interfere each other.
Hi @leledumbo , sorry before it for mentioning you..can you give me detailed instruction how to get working *no-support-for-this-app-on-this-forum* with MIUI 10.0.5.0, also can you attached here what magisk module to fix and *no-support-for-this-app-on-this-forum* you've used that worked in yours, i've tried use your given module above but nothing *no-support-for-this-app-on-this-forum* works, mostly FC and black viewfinder.

I've success using *no-support-for-this-app-on-this-forum* pixel3mod but sometimes it can't shoot, shutter button doesn't response then anded with FC.
 
Last edited:

leledumbo

Members
Jul 26, 2013
357
52
Hi @leledumbo , sorry before it for mentioning you..can you give me detailed instruction how to get working *no-support-for-this-app-on-this-forum* with MIUI 10.0.5.0, also can you attached here what magisk module to fix and *no-support-for-this-app-on-this-forum* you've used that worked in yours, i've tried use your given module above but nothing *no-support-for-this-app-on-this-forum* works, mostly FC and black viewfinder.

I've success using *no-support-for-this-app-on-this-forum* pixel3mod but sometimes it can't shoot, shutter button doesn't response then anded with FC.
I only use this one:
Screenshot_2018-11-12-23-54-51-636_com.topjohnwu.magisk.png

Which is exactly the one I attach, it already does everything required. For the *no-support-for-this-app-on-this-forum* version I use: GCam_Pixel3Mod_1_build.6.1.013
 

jeamy

Members
Dec 18, 2013
36
20
I only use this one:

Which is exactly the one I attach, it already does everything required. For the *no-support-for-this-app-on-this-forum* version I use: GCam_Pixel3Mod_1_build.6.1.013
OMG...i've used v.GCam_Pixel3Mod_1.1 (this version is so buggy), what about night mode in v.1, is it black viewfinder in yours too..?, because in mine it's just black screen. Anyway thanks for your detailed info.
 
  • Like
Reactions: fabiomaga