New Can't disable auto contrast (POCO X3, MIUI 12.0.3)


jezersek

Members
Oct 30, 2020
3
3
On my phone, all greys get lighter in bright environments. Researching online I found out this is supposed to help you see in bright light. But having dark mode enabled it actually makes things worse because the background gets lighter and the text is white so there is actually less contrast. Plus there is an ugly dark shadow around light objects. I do not like this "feature" and want to turn it off but it seems to be impossible to do.

32584

Notification center: left: normal lighting conditions, right: flashlight on the brightness sensor

32585

Gmail app: left: normal lighting conditions, right: flashlight on the brightness sensor visible dark shadow around light objects

I have tried the following settings:
  • auto brightness is off
  • sunlight mode is off
  • dark mode is on
  • display > dark mode > adjust contrast automatically is off
  • display > color scheme is set to standard
but unfortunately, none of these settings have any effect on the issue.

Surfing the web, I found that many other people are experiencing the same issue but no solution that would work for me:
Technical specifications of my phone are:
POCO X3 NFC
MIUI version (For Poco): MIUI Global 12.0.3 Stable (QJGEUXM)
Android version: 10 QKQ1.200512.002
Android security patch level: 2020-09-01
I'd be delighted if this bug gets fixed as soon as possible. In the meantime, I'd be also interested in any workarounds even if rooting is required.

Best regards
 

jezersek

Members
Oct 30, 2020
3
3
I am using stock ROM (versions in the original post) and am experiencing this issue since I bought the phone.
 

Oxnap

Members
Jul 10, 2020
184
55
I am using stock ROM (versions in the original post) and am experiencing this issue since I bought the phone.
Well, let me tell you that this forum is for a Custom ROM called Xiaomi EU. We are not official support or related to Xiaomi :)