Resolved Can't set physical keyboard layout, Stable 12.1.1 (and previous versions)


tusenkonstnar

Members
Sep 9, 2020
52
20
Using a Mi 10 Ultra with stable ROM's.
I often use physical external BT-keyboards. I live in Sweden and have Swedish layout on the keyboards that I use, when using them with a Samsung or Huawei phone I have to set the keyboard layout to nordic for the mapping to be correct.

On my Mi 10 Ultra this is IMPOSSIBLE and there seems to be at least two problems involved.

1) Even if I go to settings and choose "Swedish" with the slider the setting won't stick. Have to repeat it several times and all of a sudden the phone has finally accepted the setting.

2) Even when it says "Swedish" it keps using the ordinary English layout. Meaning that if I press "minut" i get "division". If i press "ö" I get ";" etc.... I have tried with different keyboards and they all works with several other phones so the problem is whithin Mi 10 Ultra and not with the keyboards.

Is there any known work-around that makes it possible to use a physical keyboard with a layout that is not English?

BR
 

thirnanox

Members
Mar 28, 2021
1
3
Hello,

I've a Mi 11 and I've the same issue with a French Bluetooth Keyboard.So I'm interest if you had found a solution since last september.
I wan't to know if Xiaomi planed to correct this issue as I've no issue on my old phone that WAS NOT a flag ship of another vendor...

DM
 

tusenkonstnar

Members
Sep 9, 2020
52
20
No I have not managed to solve the issue. For me that is using it both as a phone and as a "computer" (i.e using physical keyboard if I need to send a lot of work-emails when not in office) this is a really dissadvantage. Sad to hear that it is a generic problem also on Mi 11 (I was planning on bying a Mi 11 Ultra) but this might hold me back from that.

Best Regards

P.s Would be happy if someone knew some sort of solution to the problem
 

BenMiller285291

Members
Apr 3, 2021
1
3
Same same issue on Mi9 with latest updates. Really ridiculous! Exact same issue as described by @tusenkonstnar above.
With one of the countless attempts I made to find a way around this bug I accidentally set the physical keyboard language to Arabic (!!!) but no matter what I tried - no way of changing this back to English or any other intended language setting. Anyobdy @Xiaomi monitoring these bugs here?
 

mahdi.a

Members
May 26, 2021
3
15
Hello, I had the same issue in Xiaomi Mi 11 Lite, it says french (azerty) but it's still qwerty when I type.

For some reason the layout of the physical keyboard depends on your virtual one.
If you are not using the default virtual keyboard, you need to find the setting to change it from your virtual keyboard.
In my case, I am using Multiling O Keyboard https://play.google.com/store/apps/details?id=kl.ime.oh and I found a setting called "Remap keys", disabled it and my physical keyboard works as expected.

Another workaround is to switch to default virtual keyboard before connecting your physical keyboard.

Hope this helps
 
  • Like
Reactions: tusenkonstnar

tusenkonstnar

Members
Sep 9, 2020
52
20
Same same issue on Mi9 with latest updates. Really ridiculous! Exact same issue as described by @tusenkonstnar above.
With one of the countless attempts I made to find a way around this bug I accidentally set the physical keyboard language to Arabic (!!!) but no matter what I tried - no way of changing this back to English or any other intended language setting. Anyobdy @Xiaomi monitoring these bugs here?
I do not think so. I have reported it both here and to Xiaomi (hoping to get a fix of this bug directly in Xiaomis own source code) but no solution whatsoever. Seems also like the bug is present in a lot (all?) of modells.
 

tusenkonstnar

Members
Sep 9, 2020
52
20
Hello, I had the same issue in Xiaomi Mi 11 Lite, it says french (azerty) but it's still qwerty when I type.

For some reason the layout of the physical keyboard depends on your virtual one.
If you are not using the default virtual keyboard, you need to find the setting to change it from your virtual keyboard.
In my case, I am using Multiling O Keyboard https://play.google.com/store/apps/details?id=kl.ime.oh and I found a setting called "Remap keys", disabled it and my physical keyboard works as expected.

Another workaround is to switch to default virtual keyboard before connecting your physical keyboard.

Hope this helps
Thanks, I will try this out.