Can't Start Camera


Mar 30, 2012
16
1
23
#1
after updating to Lollipop Miui (now I have MIUI 7.4 by xiaomi.eu 6.5.5 beta, but error was present also in last week ROM)
Whatsapp says"can't start camera" and other third party apps cannot open front camera, they just get stuck
System Camera app works perfectly
 
Mar 30, 2016
6
0
11
#2
after updating to Lollipop Miui (now I have MIUI 7.4 by xiaomi.eu 6.5.5 beta, but error was present also in last week ROM)
Whatsapp says"can't start camera" and other third party apps cannot open front camera, they just get stuck
System Camera app works perfectly
give permission to third application via security..tried it again

Sent from my 2014811
 
Mar 30, 2016
6
0
11
#4
I already tried but it didn't work.
With Camera Zoom the rear camera works, but not the front camera... so I think it's not a matter of authorizations
try to wipe cache and dalvik chace in twrp menu...don't wipe data or system..reboot and tried it again

Sent from my 2014811
 
Mar 30, 2016
6
0
11
#5
try to wipe cache and dalvik chace in twrp menu...don't wipe data or system..reboot and tried it again

Sent from my 2014811
if that methode not work, you can try to re flash rom via fastboot methode..you need pc for that..read instruction how to flash via fastboot

Sent from my 2014811
 
Mar 30, 2016
6
0
11
#7
Is it different from flashing via twrp?

Inviato dal mio 2014813 utilizzando Tapatalk
yup,...and it's different...you must download again rom with .tgz extension...flash it via pc..read instruction how to flash via fastboot..
btw...have you wipe chache dan dalvik chache with twrp?

Sent from my 2014811
 
Mar 30, 2012
16
1
23
#8
yup,...and it's different...you must download again rom with .tgz extension...flash it via pc..read instruction how to flash via fastboot..
btw...have you wipe chache dan dalvik chache with twrp?

Sent from my 2014811
Yes, I wiped cache and dalvik/art from twrp but the situation is the same
I'll try to flash via fastboot then... but I am sure that if I downgrade to KK the camera will work again. I'll let you know, thanks

But you didn't answer to my question: what is the difference if I flash a ROM with twrp and if I flash with fastboot?

Thanks again

Inviato dal mio 2014813 utilizzando Tapatalk
 
Mar 30, 2012
16
1
23
#9
With Fastboot rom I flashed 6.4.14 where camera is working.
I tried flashing latest 6.5.5 with TWRP and it's not working anymore.
I back again to 6.4.14....
 
Mar 30, 2012
16
1
23
#11
I solved in this way.
I installed the global stable with fastboot, then installed twrp then flashed another global stable with twrp. Definitely downgraded to KK

Inviato dal mio 2014813 utilizzando Tapatalk
 
Last edited:
May 1, 2016
8
1
13
#12
Your ROM version was correct?
I had problems with camera too and my problem was wrong ROM 88047.
Correct is for 2014813 --> xiaomi.eu_multi_wt86047_****.zip