Change (physical)Keyboard layout


tusenkonstnar

Members
Sep 9, 2020
54
20
  • Using an external BT-keybord with a non-English layout (QUERTY but with the nordic languages)
  • Going to Settings->Additional settings-> Language & input->Keyboard, mouse and trackbad->Settings för my physical keyboard
  • Then I get to a long list where I choose langugage but when I thereafter type on the keyboard it keeps giving me English layout and not the signs that shall be on tje keyboard
Is there any way to work around this? Previously I have been using Samsung and Huawei and then this has been working, is there no way I can use my extrernal keyboard (with correct language) together with my Mi 10 Ultra?
 

B!GBOY

Members
Dec 27, 2010
148
55
I did it the same way as you described. In my screenshot you can see the layout is shown under keyboard's name. it should also remember it after the device is reconnected.
Screenshot_2021-03-20-21-24-52-933_com.android.settings.jpg
 

Attachments

  • Screenshot_2021-03-20-21-24-52-933_com.android.settings.jpg
    Screenshot_2021-03-20-21-24-52-933_com.android.settings.jpg
    147 KB · Views: 724

tusenkonstnar

Members
Sep 9, 2020
54
20
Hi, mine looks similar(but swedish) but it just SAYS it uses swedish but it does not. It still uses english keyboard layout. (Have tested the keyboards with 3 other units so the error is not within the keyboards.

A strange thing is that it says "default" in my other attachment here. I would expect it to say swedish. Is it the same for you?

BR
 

Attachments

  • IMG_20210320_231323.jpg
    IMG_20210320_231323.jpg
    872.9 KB · Views: 381
  • IMG_20210320_231353.jpg
    IMG_20210320_231353.jpg
    1.2 MB · Views: 346

B!GBOY

Members
Dec 27, 2010
148
55
Hi, mine looks similar(but swedish) but it just SAYS it uses swedish but it does not. It still uses english keyboard layout. (Have tested the keyboards with 3 other units so the error is not within the keyboards.

A strange thing is that it says "default" in my other attachment here. I would expect it to say swedish. Is it the same for you?

BR
Thats odd. maybe others know more.

Yes mine also says default but it works as a German keyboard ( correct symbols and everything )
 

tusenkonstnar

Members
Sep 9, 2020
54
20
Is there any info regarding whether tihis is something that will be solved? (I have given up on my Mi 10 Ultra and now using my P30 pro instread for work but I am interested in if it will be adressed or not because depending on this I will either but a Mi 11 Ultra or not).
 

mahdi.a

Members
May 26, 2021
3
15
Hello, I have the same issue in Xiaomi Mi 11 Lite, it says french (azerty) but it's stil qwerty when I type.

EDIT:
I managed to fix it, for some reason the layout of the physical keyboard depends on your virtual one.
If you are not using the default virtual keyboard, you need to find the setting to change it from there.
In my case, I am using Multiling O Keyboard https://play.google.com/store/apps/details?id=kl.ime.oh and I found a setting called "Remap keys", disabled it and my physical keyboard is working as expected now.
Hope this helps.
 
Last edited:

tusenkonstnar

Members
Sep 9, 2020
54
20
Hi and thanks for your input.
I tried downloading the suggested app. I had to enable remap keys and after that I could (partly) use my keyboard.
What happened now is that Swedish letters like "å", "ä" and "ö" exists and are represented by the same keys as a Swedish layout suggests. My first thought was then "Nice, sad to have to switch between keyboars but that is easily done".
However, other symbols lite "/" (that shall be typed by "shift" + "7").
In short words, now I have the correct layout of the alphabet but not for other sympbols that still can be all over the place.


BR/Erik

P.s This bug has been reported both on xiaomi.eu and directly to Xiaomi but no fix is in sight and the respons is nothing but silence.
 

tusenkonstnar

Members
Sep 9, 2020
54
20
Hi, for me or works on my Huawei p30pro and ok an old Samsung but not with any of my Xiaomis.
Tried to install the app but my problem still is that the phones ignore my choice :(
 

dexterv

Members
Jul 22, 2020
652
102
Yes, the same thing is happening on my RN8 and I am pretty safe to assume it is Xiaomi's fault. I figured if you hold the layout for a few seconds it will save it and show it instead of Default but it will still use qwerty.
 

tusenkonstnar

Members
Sep 9, 2020
54
20
As mentioned I have reported the bug both here and to Xiaomi directly (without any sort of responce). I guess the choice then is whether it is ok not being able to use the phone fully as workingtool as the prize to pay for having a "kick-ass-camera".
 
  • Haha
Reactions: dexterv

dexterv

Members
Jul 22, 2020
652
102
As mentioned I have reported the bug both here and to Xiaomi directly (without any sort of responce). I guess the choice then is whether it is ok not being able to use the phone fully as workingtool as the prize to pay for having a "kick-ass-camera".
It shouldn't be like that. Anyway, I wrote to Xiaomi proper as well but the hopes there are quite low. Let'see if the wizards from the dev team can help us. i have posted in the weekly thread.
 

King4

Members
Nov 13, 2021
1
3
Hey, I had the same problem with my Redmi 9T but I found the solution.
When you click Swedish language, you can't automatically use it.

What you need to do is hold CONTROL and press SPACE at the same time.
It will change from standard QWERTY to any language you clicked on.
 

tusenkonstnar

Members
Sep 9, 2020
54
20
i do not manage to get it to work with pressing shift controll.
Is there anything more that should be done to get this fix to work
 

omnimon

Members
Nov 24, 2021
2
3
Don't know if this is helpful, however:
when you click on set up keyboard layouts and you see the list of all the languages, select ONE layout (if you select more than one layout, it will stay with the previous layout), then, tap the arrow in the top left corner.

Xiaomi 10T MIUI global 12.5.3
physical keyboard 1byone with touchpad

With this trick I was able to switch from the german QWERTZ layout to an italian QWERTY layout, however, the special letters does not match. For example, if you press "è" it gives you "[" which should be given by pressing AltGr+"è".
Anyone knows how to fix? please not a manual remap of each key, all the special character to the side of the keyboard have this issue.

I tested the same keyboard with my samsung tablet S6 Lite (same app microsoft swiftkey and same layout italian) and it worked perfectly fine! All the letters are typed correctly even with shift and AltGr. So this should be on Xiaomi side.
 
Last edited:

TomKr

Members
Dec 25, 2021
2
3
Don't know if this is helpful, however:
when you click on set up keyboard layouts and you see the list of all the languages, select ONE layout (if you select more than one layout, it will stay with the previous layout), then, tap the arrow in the top left corner.

Xiaomi 10T MIUI global 12.5.3
physical keyboard 1byone with touchpad

With this trick I was able to switch from the german QWERTZ layout to an italian QWERTY layout, however, the special letters does not match. For example, if you press "è" it gives you "[" which should be given by pressing AltGr+"è".
Anyone knows how to fix? please not a manual remap of each key, all the special character to the side of the keyboard have this issue.

I tested the same keyboard with my samsung tablet S6 Lite (same app microsoft swiftkey and same layout italian) and it worked perfectly fine! All the letters are typed correctly even with shift and AltGr. So this should be on Xiaomi side.
You are right, I faced the same with my Poco X3 NFC - even when you manage to choose your language (for me German) the special characters like öäü..are not available. I have tried different BT keybords already with same issue...So still miscoding from Xiaomi I guess..
 

TomKr

Members
Dec 25, 2021
2
3

tusenkonstnar

Members
Sep 9, 2020
54
20
I have been waiting for a solution since ibought my Mi10 Ultra.
I took for granted that such a serious bug would not turn up in mi11 ultra also.
Obviously the bug are present in a lot of the phones (all?) and nobody cares to fix the problem.I love the camera but I also use my phone at work so there will be no more xiaomi for me sadly enough.
 

Teclado

Members
May 4, 2022
1
3
I could not configure in Spanish my Qilive Q3572 bluetooth keyboard (also branded as "newo" or VIMI) in my Xiaomi Redmi Note 8 until I deactivated the "Accessibility Menu", which is within Additional Settings -> Accessibility. I just deactivate "Accessibility Menu" and I was effective the language configuration of my keyboard. But with the "Accessibility Menu" activated, the language settings of the physical keyboard was not effective: I could choose the language of the physical keyboard, but the keyboard operated in English layout. I do not know if the "bug" of accessibility and the physical bluetooth keyboard layout is a problem only applicable to my Xiaomi device, if my antivirus has something to do or why Android mantains the English layout after changing the language configuration of the physical keyboard when I have active (ON) the "Accessibility Menu". Note: the accessibility menu was active because I was asked by my Bitdefender antivirus to monitor my device. This bug happens in my Qilive Q3572 bluetooth keyboard but not in my Rapoo BT 4 keyboard.
#######################################################################3
Yo no pude configurar en español mi teclado bluetooth Qilive Q3572 (también fabricado con nombres newo o VIMI) en mi Xiaomi Redmi Note 8 (Android) hasta que no desactivé el "Menú de accesibilidad", que está dentro de Ajustes adicionales -> Accesibilidad.
Fué desactivar "Menú de accesibilidad" y ya pude configurar la disposición del lenguaje de mi teclado en español con el procedimiento estándar. Pero con el "Menú de accesibilidad" activado, no eran efectivo los ajustes del teclado físico: yo podía elegir el idioma del teclado físico, pero Android no me hacía caso. No sé si el "bug" de la accesibilidad y el teclado físico bluetooth es un problema solo aplicable a mi dispositivo Xiaomi y mi teclado Qilive, si mi antivirus tiene algo que ver o por qué "conjunción de planetas" no me hace caso al cambiar el idioma del teclado físico cuando tengo activo (ON) el "Menú de accesibilidad". Nota: el menú de accesibilidad lo tenía activo porque me lo pidió mi antivirus Bitdefender para poder supervisar mi dispositivo. Este bug sucede en el teclado Qilive pero no en mi otro teclado bluetooth (Rapoo BT 4).
 
Last edited: