Connection Issue


Feb 25, 2020
Hello guys,

I would like to ask your help in the following frustrating issue:

I have a Mija Home with a 360 Camera, 3x Mi Smart Plugs (Wifi) (and 7 sensors).
Yesterday there was a power outage meanwhile I was working and I experienced that 2 of 3 plugs are offline, 1 was working as it used to.

So to re-connect the 2 offlien devices, I re-plugged the plugs and after that reseted them.
- Plugs are failing at the last step saying that there might be a problem with my Wifi settings (check out password, 2.4 etc.), which is false.
I believe that my Wifi network should be fine as I was able to re-connect the Gateway and 360 Camera to the same network.

Additional info:
Meanwhile the plugs are failing at the last step giving an error message, each of them are lighting in blue.
Plugs can connect to a Wifi Hotspot (hosted via phone), but still not to my Wifi .
- I have a ZTE F668 router, is there something I should set/change?

Interference? Any other ideas?
I tried to reset the only one working plug, but after that I get the same error, failing at the last step.
- I'm trying to connect the plugs one by one. Only one in the same time, others are not getting electricity.

I removed the plugs from Mi Home application already.
- At least I can say that I can not see any plugs listed under my devices in the application.

Shall I change something in my router settings? Any other ideas?
I changed the hostname becasuse I was thinking that something duplicates the connection which cause this issue, but it didn't help.
Also, I tried to add an other router in bridge mode and connect to that "new" network but the plugs are failing at the last step again (different name, pw).

Shall I create a new virtual home, under my xiaomi account? Any other ideas?
I can't add the plugs for example on my Girlfriend's phone to her Home (we had the camera first),
We are getting the same connection error there, same Wifi.

Plugs are working because they can connect to a Wifi hotspot but not to my network, meanwhile other Mi smart devices can connect to the same network.
What the hell is going on.
Someone, please help.