Invalid Dark Mode switches itself


der_Kief

Members
Aug 26, 2017
47
20
I recently switched to latest weekly 9.3.1 and Dark Mode seems to be buggy (maybe it was there also in recent builds ... idk)
I disabled Dark Mode (Always off) but every once in a while Dark Mode switches back itself to Automatic.
I'm not quite sure if this is an Xiaomi or EU ROM problem.
This is very annoying .... not everybody likes this Dark Mode
Is there any workaround to permanent disable the Dark Mode ?

Device: Poco F1
Build: 9.3.1
 

Aramazia Kin

Members
Aug 25, 2017
21
15
This is happening on my Mi8 on 9.3.1 (and the past few builds) too, no matter how many times I turn off dark mode it turns back on again a short while later.
 

Igor Eisberg

Patch/Mod Developer
Staff member
Oct 6, 2016
1,812
297
We are not able to reproduce the issue ourselves, and couldn't find any potential source of the problem...
 

bayp4amd

Members
Jan 29, 2012
28
15
Probably because you are using app that using dark mode
If you using an app using dark mode, the system will automatically change the mode into dark
You can switch to white theme in your application to avoid auto switch to dark mode in system
 

hk miui

Members
Jul 13, 2017
138
40
I just tested it with my F1.

1) Closed all apps.
2) Turn OFF night mode
3) Turn off the screen.
4) after less than one minute, I turned on the screen, it becomes night mode...
 

hk miui

Members
Jul 13, 2017
138
40
I can reproduce the issue by the following steps:

1) Set Night Mode OFF
2) Clear ALL apps
3) after a few seconds, the night mode turned ON

guess it's something with memory management?
 

Aramazia Kin

Members
Aug 25, 2017
21
15
We are not able to reproduce the issue ourselves, and couldn't find any potential source of the problem...
Could it be something to do with moving the dark mode option to dev settings? I had dark mode set to on when I flashed the build that moved the option to dev settings so could something funky be happening there?
 

complicazio

Members
Sep 20, 2016
52
20
I recently switched to latest weekly 9.3.1 and Dark Mode seems to be buggy (maybe it was there also in recent builds ... idk)
I disabled Dark Mode (Always off) but every once in a while Dark Mode switches back itself to Automatic.
I'm not quite sure if this is an Xiaomi or EU ROM problem.
This is very annoying .... not everybody likes this Dark Mode
Is there any workaround to permanent disable the Dark Mode ?

Device: Poco F1
Build: 9.3.1


No, unless you log exactly while reproducing the issue, only then it may be useful. Just a random log won't do any good.

same problem on chiron reported several times
 
Last edited:
  • Like
Reactions: DangerousRon

Igor Eisberg

Patch/Mod Developer
Staff member
Oct 6, 2016
1,812
297
Could it be something to do with moving the dark mode option to dev settings? I had dark mode set to on when I flashed the build that moved the option to dev settings so could something funky be happening there?
Not likely. On Oreo devices there was no option in Display settings, and they are still having issues.

I can reproduce the issue by the following steps:

1) Set Night Mode OFF
2) Clear ALL apps
3) after a few seconds, the night mode turned ON

guess it's something with memory management?
Still can't reproduce on MI6.
 

NonnaWarrior

Members
Aug 5, 2018
1
13
On mi mix 3 i reproduced the case this way:
- deactivated dark mode
- clean the memory
- open google message app (in dark mode)
- dark mode is active again

and again:

- deactivated dark mode
- open google message (dark mode)
- dark mode is not activated
- clean the memory
- open google message
- dark mode is activated

then:
- set google message in clear mode (?)
- deactivated dark mode
- open google message
- dark mode is not activated
- set google message app in dark mode
- dark mode is activated

i try with other apps that have dark mode but no way, only google message reproduce the bug.
 
  • Like
Reactions: complicazio

Igor Eisberg

Patch/Mod Developer
Staff member
Oct 6, 2016
1,812
297
On mi mix 3 i reproduced the case this way:
- deactivated dark mode
- clean the memory
- open google message app (in dark mode)
- dark mode is active again

and again:

- deactivated dark mode
- open google message (dark mode)
- dark mode is not activated
- clean the memory
- open google message
- dark mode is activated

then:
- set google message in clear mode (?)
- deactivated dark mode
- open google message
- dark mode is not activated
- set google message app in dark mode
- dark mode is activated

i try with other apps that have dark mode but no way, only google message reproduce the bug.
It's not our problem if a Google app causes this.
 

complicazio

Members
Sep 20, 2016
52
20
I recently switched to latest weekly 9.3.1 and Dark Mode seems to be buggy (maybe it was there also in recent builds ... idk)
I disabled Dark Mode (Always off) but every once in a while Dark Mode switches back itself to Automatic.
I'm not quite sure if this is an Xiaomi or EU ROM problem.
This is very annoying .... not everybody likes this Dark Mode
Is there any workaround to permanent disable the Dark Mode ?

Device: Poco F1
Build: 9.3.1
On mi mix 3 i reproduced the case this way:
- deactivated dark mode
- clean the memory
- open google message app (in dark mode)
- dark mode is active again

and again:

- deactivated dark mode
- open google message (dark mode)
- dark mode is not activated
- clean the memory
- open google message
- dark mode is activated

then:
- set google message in clear mode (?)
- deactivated dark mode
- open google message
- dark mode is not activated
- set google message app in dark mode
- dark mode is activated

i try with other apps that have dark mode but no way, only google message reproduce the bug.
The problem seems to be the dark mode of Google message.

Thanks Italian bro
 

TI_Jonathan

Members
Mar 5, 2019
5
3
Hello
I'm not sure if it's related:

I set Night Mode to automatic,
I open Android Auto and close
I go into the settings and the Night Mode is changed to off

I already tested the developer options in AA as defined by the Smartphone or as defined by the Car, but the same thing happens

sorry my english bad

Mi 8 MIUI version 9.3.1
 
Last edited:

Igor Eisberg

Patch/Mod Developer
Staff member
Oct 6, 2016
1,812
297
Hello
I'm not sure if it's related:

I set Night Mode to automatic,
I open Android Auto and close
I go into the settings and the Night Mode is changed to off

I already tested the developer options in AA as defined by the Smartphone or as defined by the Car, but the same thing happens

sorry my english bad

Mi 8 MIUI version 9.3.1
Dark mode behavior is being altered by Google Play Services while using Android Auto / Car Mode. Nothing we can do about it.
 

DangerousRon

Members
Jun 3, 2016
45
20
I was having problem with dark mode since its been introduce on my mi mix 2 Chiron
And I just switch dark mode off in Google message to see if that is something to do with it . I will report back later !! I really hope that will fix the issue !! But if thats the problem how can an individual app not even related to the system settings could interfere with a system settings ???
 
  • Like
Reactions: complicazio

Igor Eisberg

Patch/Mod Developer
Staff member
Oct 6, 2016
1,812
297
I was having problem with dark mode since its been introduce on my mi mix 2 Chiron
And I just switch dark mode off in Google message to see if that is something to do with it . I will report back later !! I really hope that will fix the issue !! But if thats the problem how can an individual app not even related to the system settings could interfere with a system settings ???
Ask Google.
 
  • Like
Reactions: DangerousRon