Fastboot Rom For Redmi 2 Pro Hm201483=wt8604=hm2xtdpro

Discussion in 'Xiaomi Redmi 2 4G/LTE' started by Bzidroglio, Nov 16, 2016.

  1. Bzidroglio

    BzidroglioMembers

    Oct 9, 2016
    17
    7
    13
    Male
    I've been seeing a lot of people with problems with this model, most problems come from flashing the wrong fastboot rom, so here you have the correct fastboot rom:

    https://megadysk.pl/s/G6LBkP

    (short tutorial, you have lots of complete and detailed ones online...)
    All you need is in the link.
    1º Install MiFlashSetup-Beta
    2º Extract wt86047_pro_images_6.9.29_20160805.0000.29_5.1_cn_01f4907ed1 so you end up with a folder with the same name.
    3º Copy the folder to c:\ (you should also change its name to something short like "wt86047")
    4º Open Miflash, select the folder, put your phone in fastboot mode and flash.
    5º Flash twrp and the latest xiaomi.eu rom (I attached the 6.11.10 one)

    If you need any help feel free to ask.

    These are the actual files I flashed on my HM2014813
     
    chapdis and severica25 like this.
  2. tu_79

    tu_79Members

    Nov 24, 2016
    6
    0
    11
    Male
    #2tu_79,Nov 24, 2016
    Last edited: Nov 25, 2016
    Thanks! You are a life saver.

    Ok, I've installed first ROM and twrp. It works well, but only in english. Then I try with the unofficial EU ROM, but it says I'm trying to install a wt86047 ROM on a HD2014813 device. Guess I need to find that other ROM to make it into my language.

    EDIT: I couldn't find the eu version, so I ended up flashing a G27 distro for MIUI7. That's the only one I've found explicitly for the 2014813. There are some translations issues, though.
     
  3. Bzidroglio

    BzidroglioMembers

    Oct 9, 2016
    17
    7
    13
    Male
    That's strange, wt86047 is the HM2014813.
    Did you try to install xiaomi.eu latest rom? It's the one with HM2XTDPRO in its name.
    I think I've seen some one with that problem some time ago. I will try to find the solution...
     
  4. tu_79

    tu_79Members

    Nov 24, 2016
    6
    0
    11
    Male
    I did try the one in your repository. Apparently I need the one without 'PRO' in its name. The ROM I installed is from another cooker, MIUI7_GT23_Stable_HM2014813_V7.1.5.0, and works. Some things aren't translated, and night mode doesn't work properly, so I'm still willing to try xiaomi.eu version.
     
  5. severica25

    severica25Members

    May 31, 2016
    611
    310
    102
    Male
    #5severica25,Nov 25, 2016
    Last edited: Nov 25, 2016
    First be very sure that you have redmi 2 lte/4g called hm 2014813.
    Remove battery, check back of phone.
    Second thing, twrp gives you a error because it could be that you are trying to install lolipop version of rom(5.1 miui rom) and atm you have Twrp for flashing only kitkat(4.1) roms.
    On this site roms are also divided by android baseline version, so if you really have hm2014813 device then for you have this situation, one group of roms are for "hm2014813" device and one for "wt86047" they are both same device BUT "hm 2014813" means that you have Twrp for kitkat roms and that you wish to install kitkat(4.1) MIUI rom while "wt86047" means that you have Twrp for lolipop roms(5.1) and you wish to install lolipop(5.1) miui roms.
    So, first you need to flash by fastboot twrp for wt86047(link is in rom section of forum) then you could install new eu lolipop rom aka wt86047 roms.
    For reference look at this picture and try to understand hm2014813 and wt86047 difference you can notice that there is 2 different android version and zip file have difference in name(with PRO in name are 5.1 android version roms, without it are 4.4 android versions of roms)
    [​IMG]
    Sent from my 2014813 using Tapatalk
     
  6. tu_79

    tu_79Members

    Nov 24, 2016
    6
    0
    11
    Male
    Under battery it says: 2014813 TD-LTE(chinese words). I bought it as a Redmi 2 Pro LTE 2GB RAM.
    It sure is complicated. I have no idea which version of TWRP I installed, it was just called TWRP_HM2014813.

    It seems that the phone can handle android 5, as I installed first MIUI8 (but modem driver didn't work, and when I flashed old driver, then Settings app CTD), other than those problems, it felt fast.

    Should I try with another TWRP in order to install MIUI8? If so, where to find it?

    You are being most helpful, thanks!
     
  7. severica25

    severica25Members

    May 31, 2016
    611
    310
    102
    Male
    #7severica25,Nov 26, 2016
    Last edited: Nov 26, 2016
    Depends if you wanna try miui 8 lolipop. If you wanna try then install twrp for wt86047 and latest miui 8 for wt86047.
    If you'll wish to go back to kitkat rom or you'll have some problems then flash first official rom again through Miflash. Reason why you need again to flash official rom is because of changes in partitions, if you installed eu lolipop roms.
    So, try lolipop miui 8 eu rom by flashing newer twrp for wt86047 by fastboot then flash latest weekly eu miui 8 rom. I would advise you to wipe also data/internal memory partition also so that will be fresh installed rom.
    Twrp lolipop version for wt86047 link: https://www.androidfilehost.com/?fid=24459283995314651

    Twrp fastboot adb command look for on first page of this link: https://xiaomi.eu/community/index.php?threads/36315/

    Rom link: https://www.androidfilehost.com/?fid=529152257862684626

    Sent from my 2014813 using Tapatalk
     
  8. tu_79

    tu_79Members

    Nov 24, 2016
    6
    0
    11
    Male
    I was a happy man because thanks to your links I was able to recover my brick phone back to MIUI7. Now I am a happier man with MIUI8 :D
    It works!
     
  9. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    Excellent, I'll try shortly
     
  10. miui-fan

    miui-fanMembers

    Mar 19, 2017
    1
    0
    1
    Hi, I have problems with my Redmi 2 phone, no network service, everything else working correctly.

    Phone info:
    Xiaomi Redmi 2 Pro 2GB RAM
    Model: wt88047
    Android version: 5.1.1 LMY47V
    MIUI version: MIUI by xiaomi.eu 8.2 Estable 8.2.1.0(LHJCNDL)
    CPU: Quad-core 1,2GHz
    RAM: 2,00 GB

    Under the battery:
    2014813 TD-LTE
    CMIT ID: 2014CP6138

    Oh! and IMEI info shows:
    IMEI (slot 1)
    868..........
    IMEI SV (slot 1)
    14
    IMEI (slot 2)
    868........ same as 1
    IMEI SV (slot 2)
    00

    What is IMEI SV?

    Please, please, Could any of you tell me what is the correct steps, ROM, etc. to make phone connect to network service again? After following so many threads trying to find the solution I'm really desperate!!!

    Thanks in advance.
     
  11. krsv80

    krsv80Members

    Sep 13, 2016
    19
    4
    15
    Male
    You need to flash correct ROM. Your is wt86047, but flashed wt88047
     
  12. mirko.mosi

    mirko.mosiMembers

    Jan 16, 2017
    30
    17
    20
    Male
  13. Patit

    PatitMembers

    May 17, 2012
    83
    15
    28
    Male
    #14Patit,Apr 18, 2017
    Last edited: Apr 19, 2017
    I've got a redmi 2 (2014813) that I updated weekly with xiaomi.eu ROM. During last update phone got stuck and on forced reboot it appeared the message "Encryption Unsuccessful Encryption was interrupted and can't complete. As a result, the data on your phone is no longer accessible." Since I tried to flash official MIUI to restore phone without success (tried mi flash tool manual fastboot, edl, read dozens of threads on different forums). I get the feeling that emmc might be corrupted as theonlyu error i get on manual fastboot flashing is

    Code:
    C:\Temp\wt86047_pro_images_7.4.13_20170413.0000.00_5.1_cn\images>fastboot flash partition gpt_both0.bin
    target reported max download size of 268435456 bytes
    sending 'partition' (33 KB)...
    OKAY [  0.006s]
    writing 'partition'...
    FAILED (remote: failed to write partition)
    finished. total time: 0.081s
    All other flash complete successfully. I also went to adb shell to check partition table

    Code:
    /sbin # [6nparted /dev/block/mmcblk0
    GNU Parted 1.8.8.1.179-aef3
    Using /dev/block/mmcblk0
    Welcome to GNU Parted! Type 'help' to view a list of commands.
    (parted) p
    p
    Model: MMC HAG2e (sd/mmc)
    Disk /dev/block/mmcblk0: 15.8GB
    Sector size (logical/physical): 512B/512B
    Partition Table: gpt
    
    Number  Start   End     Size    File system  Name      Flags
     1      67.1MB  134MB   67.1MB  fat16        modem
     2      134MB   135MB   524kB                sbl1
     3      135MB   135MB   524kB                sbl1bak
     4      135MB   136MB   1049kB               aboot
     5      136MB   137MB   1049kB               abootbak
     6      137MB   138MB   524kB                rpm
     7      138MB   138MB   524kB                rpmbak
     8      138MB   139MB   524kB                tz
     9      139MB   139MB   524kB                tzbak
    10      139MB   140MB   524kB                hyp
    11      140MB   141MB   524kB                hypbak
    12      141MB   142MB   1049kB               pad
    13      142MB   143MB   1573kB               modemst1
    14      143MB   145MB   1573kB               modemst2
    15      145MB   146MB   1049kB               misc
    16      146MB   146MB   1024B                fsc
    17      146MB   146MB   8192B                ssd
    18      146MB   156MB   10.5MB               splash
    19      201MB   201MB   32.8kB               DDR
    20      201MB   203MB   1573kB               fsg
    21      203MB   203MB   16.4kB               sec
    22      203MB   237MB   33.6MB               boot
    23      237MB   1310MB  1074MB               system
    24      1310MB  1646MB  336MB                cache
    25      1646MB  1679MB  33.6MB  ext4         persist
    26      1679MB  1713MB  33.6MB               recovery
    27      1745MB  1745MB  524kB                keystore
    28      1745MB  1745MB  32.8kB               config
    29      1745MB  1812MB  67.1MB               oem
    30      1879MB  15.8GB  13.9GB               userdata
    
    (parted)
    Code:
    /sbin # [6ncat /proc/partitions
    major minor  #blocks  name
    
     179        0   15392768 mmcblk0
     179        1      65536 mmcblk0p1
     179        2        512 mmcblk0p2
     179        3        512 mmcblk0p3
     179        4       1024 mmcblk0p4
     179        5       1024 mmcblk0p5
     179        6        512 mmcblk0p6
     179        7        512 mmcblk0p7
     179        8        512 mmcblk0p8
     179        9        512 mmcblk0p9
     179       10        512 mmcblk0p10
     179       11        512 mmcblk0p11
     179       12       1024 mmcblk0p12
     179       13       1536 mmcblk0p13
     179       14       1536 mmcblk0p14
     179       15       1024 mmcblk0p15
     179       16          1 mmcblk0p16
     179       17          8 mmcblk0p17
     179       18      10240 mmcblk0p18
     179       19         32 mmcblk0p19
     179       20       1536 mmcblk0p20
     179       21         16 mmcblk0p21
     179       22      32768 mmcblk0p22
     179       23    1048576 mmcblk0p23
     179       24     327680 mmcblk0p24
     179       25      32768 mmcblk0p25
     179       26      32768 mmcblk0p26
     179       27        512 mmcblk0p27
     179       28         32 mmcblk0p28
     179       29      65536 mmcblk0p29
     179       30   13557743 mmcblk0p30
     179       32       4096 mmcblk0rpmb
    /sbin # [6n
    Yet, if I try a mount, I get the Invalid argument response

    Code:
    /sbin # [6nmount -a
    mount: mounting /dev/block/mmcblk0p24 on /cache failed: Invalid argument
    mount: mounting /dev/block/mmcblk0p23 on /system failed: Invalid argument
    mount: mounting /dev/block/mmcblk0p30 on /data failed: Invalid argument
    mount: mounting /dev/block/mmcblk0p1 on /firmware failed: Invalid argument
    mount: mounting /external_sd on auto failed: No such file or directory
    mount: mounting /usb_otg on auto failed: No such file or directory
    At this point I think emmc is probably corrupted. Any ideas or suggestions? Please, avoid simply linking to threads I probably have already checked, just state your idea/opinion.

    Thanks
     

Share Our Site